Idea Fedora 23 slow start

Answered

I just try to open Idea in Fedora23. It takes like two minutes to start Idea on my computer (In windows it will less than 30s ). In that two I can't see anything. When I click the icon, not start screen or the anything other thing in the screen. 

 

Running on VMware Player with SSD:

CPU: Intel i5 3360M 4 Core

RAM: 8G

System: Fedora23  64bit

Linux Version: 4.2.3-300.fc23.x86_64 #1 SMP Mon Oct 5 15:42:54 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Java Version: java version "1.8.0_91"
                     Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
                     Java HotSpot(TM) 64-Bit Server VM (build 25.91-b14, mixed mode)

Log: 

$ ./idea.sh
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0

 

6 comments
Comment actions Permalink

I updated idea.log and dumps to  https://uploads.jetbrains.com name with:

Idea Fedora 23 slow start by Zhou Jian.log (74 kb) 
Idea Fedora 23 slow start by Zhou Jian dump.txt (19 kb) 
0
Comment actions Permalink

We need more thread dumps to understand what happens. Use jstack at 10 seconds after startup, then after 20 seconds, then after 30 seconds, etc. Provide 5-10 dumps while IDE is not responding with 10 seconds intervals.

Does it start faster if you disable the network completely?

0
Comment actions Permalink

I've uploaded my dump files 'Fedora idea slow start by choucchou dump.zip' by https://uploads.jetbrains.com .

And to my surprise, after remove my network adapater, the startup speed up. Now only 10s to startup, so what's the solution? How can I fix it?

 

0
Comment actions Permalink

Java seems to hang at at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method).

There is an issue with your DNS configuration, localhost resolution times out after some long period.

I found a Java bug that is causing this problem: https://bugs.openjdk.java.net/browse/JDK-7155683.

Verify that your host name and localhost can be resolved properly. Adjusting /etc/hosts may help.

0
Comment actions Permalink

The problem seems solved. I've found a solution by setting a hostname and add it to hosts.

The root of the problem seems like the missing of hostname.

The link list below may do help with most of the users who are also stuck with this problem. I think you can put it on the FAQ.

https://wiki.archlinux.org/index.php/Network_configuration#Set_the_hostname

 

Thanks for your helping.

0

Please sign in to leave a comment.