Javascript does not appear under code style

I have been a long time RubyMine user, and at a new company with a node code base, I decided to give Intellij a try.  However, I am having some big javascript problems.  I am unable to click through on code, refactor the code, or highlight uses of vars, etc in the file.  This led me to look at preferences and I do not have Javascript under Code Style.  I can't find a way to install it, nor a plugin for it.  What am I missing?  It is still right there in my copy of RubyMine.

2 comments
Comment actions Permalink

Make sure JavaScript Support plug-in is enabled:

http://i.imgur.com/1ztVBNe.png

See http://www.jetbrains.com/idea/webhelp/enabling-and-disabling-plugins.html for details.

0
Comment actions Permalink

Also note that JavaScript support is only available in the Ultimate edition of IDEA, not in the free Community edition.

0

Please sign in to leave a comment.