IntelliJ IDEA doesn't run new android app

I've installed IntellijIdea 14.1.4 on Ubuntu 14.04 
and I made a new Android App using android windows sdk
(replacing build tools with proper Linux build tools).
Idea can make (build) the project correctly and I've tested the apk on genymotion and it worked ,
but when you hit Run Button or Debug or Shift + F10 or what ever the way you use to run the project, it doesn't work.
nothing happens, Idea doesn't get stuck or hangs or give me an error or notification or something, it's nothin.
 when you press the Run or Debug button it's just like you never pressed it.
I made a new normal Hello world java project and it worked .
only android apps are not running.
I tried to delete ~/.IdeaIC14 which resets it's settings and it didn't work either.
1 comment
Comment actions Permalink

You may need to reinstall Android SDK for Linux from scratch, probably not all the tools from Windows Android SDK were replaced or their permissions are not set correctly.

0

Please sign in to leave a comment.