Hide Compile message

Answered

I have created macro to compile java files on save. Whenever i save java file, it automatically compile java file but it also open compile message.
Everytime i save file, it compile and this bottom panel containing compile message shows.
I don't want any compile message in bottom panel.

7 comments
Comment actions Permalink

I suppose there message window opens if there are compilation errors? The messages toolwindow is always activated if compilation ends with errors or warnings. However, you can press "hide warnings" button in the "Messages" pane's toolbar and the window won't be activated unless errors are present in result. Still, in case of errors, the window will be always activated, this cannot be changed.
I suggest that you try File | Settings | Build, Execution, Deployment | Compiler | Make project automatically option instead. This functionality tries to make project as soon as it detects changes on the disk (e.g. because you saved a file or updated a bunch of files from VCS), which seems to be exactly what you need. In case of automake all results are displayed in the "Problems" toolwindow, which is never activated automatically.

0
Comment actions Permalink

This happens if there are any deprecation warnings as well. It's annoying, I don't want to see this frame. I then have to close it and reopen the frame I was looking at before.

0
Comment actions Permalink

Try to toggle the option to show/hide warnings.

0
Comment actions Permalink

Serge Baranov: Thanks for taking some time to help with this. I've tried your solution and disabled the "Show warnings" option. However, this also results in the warnings not being shown in the messages window when I actually click on them. I need to manually reenable this option in order to see them.

This is not very ergonomic since currently, I can cycle between the different windows in IntelliJ very nicely with just my keyboard. Now I am forced to use the mouse in order to re-enable an option that I only turned off since IntelliJ was forcing me to look at a window I do not want to see. Please add an option to prevent the messages from being opened automatically on warnings and errors.

My use case for this is that I am developing a Spring Boot application using DCEVM and HotSwap agent. So when I leave the IDE and go to my browser the code is refreshed automatically. However due to the automatic focusing of the "Messages" tab, I can no longer see the console output of my running application, so now I need to get back to my IDE in order to switch back to the correct tab (which triggers another build wasting time).

Another inconvenience is that if you disable both "Show information messages" and "Show warnings" it is no longer possible to access this window (its removed from the tools window area and the keyboard shortcut no longer works). The only way to get it back is to create a compile error and re-build the application. It would be great if at least the hotkey would still work.

0
Comment actions Permalink

Hello Philipp,

What OS and IDE version do you use?

0
Comment actions Permalink

Hi Yarsolav,

 

OS: OS Name Microsoft Windows 10 Pro - Version 10.0.17134 Build 17134

IDE: IntelliJ Ultimate 2019.3 Build #IU-193.6911.18

0
Comment actions Permalink

Philipp,

There is related request on YouTrack: https://youtrack.jetbrains.com/issue/IDEA-208546.

Please vote for it.

0

Please sign in to leave a comment.