JVM for SVN

Answered

With all the SSL exploits, folks have been updating the SSL on their servers. In IntelliJ I get this error when trying to any SVN stuff:

Error:svn: E175002: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

I know how to fix this in Java 7 by enabling the correct cipher suites, but I can't seem to find which JVM gets invoked in IntelliJ to run SVN stuff. How to I get access to the command line IntelliJ runs for SVN? I get this error even when I tell it to use the command line client, which is weird because my command line client works just fine.

I have already tried adding parameters to the idea.vmoptions file.

I'm running IDEA 2016.1.2 Ultimate on OS X El Capitan.

Thank you!

4 comments
Comment actions Permalink

From the command line IDEA uses svn binary client. For some operations IDEA VM is used which can be checked/changed per https://intellij-support.jetbrains.com/hc/articles/206544879 .

0
Comment actions Permalink

I'm still having problems. I could never get it to work in 2016.1 and I just installed 2016.2.

When browsing SVN repositories I get:

Error:svn: E175002: SSL handshake failed: 'No appropriate protocol (protocol is disabled or cipher suites are inappropriate)'

I went into the SVN options and checked the box to use my command line client. Now browsing repos works, but when trying to do diffs I still get the error.

Is there anything I can do to get IntelliJ working again? The visual diff in IntelliJ is a great feature and I would like to use it.

0
Comment actions Permalink

Okay! Solved it!

The new "All" option next to SSL protocols works! I tried it before but it failed. What was tripping me up is that when changing the protocols you have to restart IntelliJ.

It is great that there is a solution. I would like to add the suggestion that when changing protocol options, the interface tells you that a restart is necessary for the change to go into effect.

1
Comment actions Permalink

This also just worked for me in PhpStorm 2016.2 (always just worked fine in the past)

0

Please sign in to leave a comment.