Subversion taking a long time to update local changes

Answered

Hi,

There seems to be a problem with SVN. It normally works fine and fast but, from time to time, it just sits there and can take up to an hour to finish. When that happens, the local changes tab displays the text 'updating...' and does not change (see screenshot).

It does not matter if I close IntelliJ and open it up again or if I just wait. I tried downgrading svn (1.9) to 1.8 and still the same problem.

This started happening after upgrading to Windows 10. Not sure if that is the problem though.

 

3 comments
Comment actions Permalink

Thanks for your reply, Serge.

For your information and for others that visit this post, I have raised https://youtrack.jetbrains.com/issue/IDEA-156911

0
Comment actions Permalink

I know this issue is quite old, but I thought I would share my findings.

I have just switched to IntelliJ and had exactly the same problem. Googling for an answer did not help, but it gave me the clue that there could be something odd/wrong with svn giving it's status information.

When I used the svn command line client (I have a Linux desktop) I noticed in the results of 'svn status' that there were two sub-directories that I had somehow managed to create which were '\'. In other words, subversion reported these directories like this:

?       module-a/src/main/java/\
?       module-b/src/test/java/\

When I removed these sub-directories, the change-lists suddenly appeared.

My guess is that the slash in the output of the subversion status command was confusing IntelliJ.

EDIT

When you look at the XML status output for these entries, they come out as:

path="module-a/src/main/java/\"

which I'm guessing would get pretty messed up as the backslash is probably changing the closing quote into a special character.

1

Please sign in to leave a comment.