Turn off JavaDoc comment auto-generating

Is it possible to customize what happen if I type "/**" and <enter>?
I want IDE to just generate ending "*/" with caret inside. But it always generate all the @return, @throws and @param annotations and I'm forced to delete these lines almost all the time.

3 comments
Comment actions Permalink

You can't modify the default behavior, but it's possible to add your own custom live template that will generate comments block, and expand it with something like jd<tab>.

0
Comment actions Permalink

+1, this is super annoying

0
Comment actions Permalink
To enable or disable generation of documentation comments
  1. Open the Settings dialog box, expand the Editor node, then expand General node, and click the Smart Keys page.
  2. In the Enter section, select or clear Insert documentation comment stub check box.

 

This got me the relief I was looking for.   Hope it helps you as well.

1

Please sign in to leave a comment.