First time setting up - invalid haxe toolkit for module xyz

Hi everyone !

I was following tutorial here to make the initial setup : http://jasonsturges.com/2014/11/28/openfl-and-haxe-in-intellij-14/
The problem is when I try to run the project I get error "Invalid Haxe toolkit for module"...

So instead of trying random things, I wanted to ask here few questions that could help me narrow down the problem.

Inside of Project Settings -> Project -  is it okay if I chose no SDK and then I set the SDK for module ? Reason is that when I am setting up SDK in Project, it doesn't allow me to select SDK from Desktop folders, after selecting the folder, and choosing it, the sdk doesn't appear in list. Only the default one in usr/lib folder appears after being selected. I tried adding Haxe folder from Desktop there, but it still didn't work after I selected it...

But it seems all works fine in Modules.
Inside of Modules folder, I have Compile with set to OpenFL , .xml file is chosen, and for Flex SDK for Flash app debugging I have selected [none] since this is Haxe, and not AS3.
Inside of Dependencies Haxe 3.1.3. is selected, and I also tried checking Library 1.7.5, but it didn't change anything...

Any idea what to do ?  I would really like to use this on my Macbook, and so far I didn't find good IDE , this one seems good so far... Thanks !

3 comments
Comment actions Permalink

I am trying now to also to install it on Windows, and on Windows adding SDKs work. I was copy pasting Haxe toolkit from Windows to Mac, so maybe on Mac there is some difference in libraries.

While testing it on Windows, I get now different error "Could not find haxelib "lime", does it needs to be installed?"
This is strange because I am using the same Haxetoolkit as I used with FlashDevelop and Sublime Text 2, so why this wouldn't work ?

0
Comment actions Permalink

After long discussion here, I still wasn't able to solve the problem. As ti seems this is not a bug, so I was redirected back here.

https://github.com/TiVo/intellij-haxe/issues/338

0

Please sign in to leave a comment.