run grails target VM parameters

How can I configure the VM parameters for Tools > Grails > Run Target?  I tried the Run > Edit Configurations > Defaults > Grails > VM parameters, but it seems to have no effect.  I was able to create a new run configuration with "test-app", which did work when I ran it (and IntelliJ amazingly displayed in a Test Results format), but I'd rather just ctrl-alt-G.

By the way, I'm trying to configure this myself because startGrails defaults GRAILS_OPTS and JAVA_OPTS to include -XX:MaxPermSize=192m.  It seems like a problem that IntelliJ doesn't use the same defaults.  It has -Xmx512M, but no permgen.  IU-98.520

3 comments
Comment actions Permalink

In current version there is no way to define VM parameter. I plan to fix it in first EAP of IDEA 10
http://youtrack.jetbrains.net/issue/IDEA-56317

0
Comment actions Permalink

No, IDEA 10.0.1
I already done functionality to provide VM parameter, but I can not include it into IDEA 10.
I attached IDEA-grails-plugin what includes this fuiture, you can put it to %IDEA_HOME%/plugins/GrailsGriffon/lib.
Attached plugin is compatible with IDEA 10.0.0 and current EAP (99.5) http://confluence.jetbrains.net/display/IDEADEV/IDEA+X+EAP



Attachment(s):
GrailsGriffon.jar
0

Please sign in to leave a comment.