Turning off CommandLineWrapper

Answered

At some point I made a change to my classpath and IDEA offered to use CommandLineWrapper to write my classpath to a text file.  It was apparently too long for the command line.  I've since fixed the issue, but don't know how to turn the CommandLineWrapper off.  Where is that setting?

Thanks

Bryan

13 comments
Comment actions Permalink

Hello Bryan,

set value to false in ]]>
in your .iws (workspace.xml) project file.

BTW Why do you want to turn it off?

Thank you
-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

At some point I made a change to my classpath and IDEA offered to use
CommandLineWrapper to write my classpath to a text file. It was
apparently too long for the command line. I've since fixed the issue,
but don't know how to turn the CommandLineWrapper off. Where is that
setting?

Thanks

Bryan

---
Original message URL:
http://www.jetbrains.net/devnet/message/5234350#5234350



0
Comment actions Permalink

What property am I looking for?

I want it to turn it off because we have a JUnit test runner that uses the classpath to search for tests.  The system property 'class.path' is just returning the rt.jar and two other jre libraries. 

0
Comment actions Permalink

I still don't know how to turn this off.. If I don't hear back, I guess I'll trash my project and start over.

0
Comment actions Permalink

Hello Bryan,

Do you find your .iws file? Do you have entry in it? Could you please close your project; change true->]]>false
and reopen the project?

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

I still don't know how to turn this off.. If I don't hear back, I
guess I'll trash my project and start over.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5235292#5235292



0
Comment actions Permalink

Hello, I too would like to be able to turn off CommandLineWrapper. Did you ever find out how to do this, I can't see an obvious property in the iws file.

Regards, Kris

0
Comment actions Permalink


Hi Anna,

What entry should we modify in the iws file?

0
Comment actions Permalink

From http://youtrack.jetbrains.net/issue/IDEADEV-35144:

To turn off dynamic classpath, remove the following item from workspace.xml or the .iws file:
<property name="dynamic.classpath" value="true"/>

0
Comment actions Permalink

Hello,

I recently built IntelliJ successfully from source, however I'm encountering a frustratingly odd problem.  When I run the build, It always starts in the CommandLineWrapper mode, and none of the menu items from the top level menu bar work.  I'm on a Mac running version 10.14.4.  Strangely enough, the UI elements within the IDE DO indeed work the way they should.  I stumbled onto this post, and have been trying various troubleshooting tactics, but I'm completely confused now.  I'm relatively new to the IntelliJ platform. I've been using it for about a year or so, but, as an engineer,  I've been writing and building software for decades. 

Could someone please explain to me in a little more detail, why a build of IntelliJ would constantly start up in CommandLineWrapper mode ?  And also, could that have something to do with why the menu is unresponsive ?  I've also looked for the dynamic classpath property in workspace.xml and It's not even in that file.  This issue really has me baffled.  

Any insight, advice, or suggestions on this matter would be greatly appreciated.  Here's some build info that may be helpful:

-------------------------------------------------------------------------------------------------------------------------------------------------

IntelliJ IDEA 2019.2 Snapshot (Community Edition)
Build #IC-192.SNAPSHOT, built on 16:12, April 1, 2019
JRE: 1.8.0_191-b12 x86_64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
macOS 10.14.4   

0
Comment actions Permalink

Please make sure to run IntelliJ IDEA on the JetBrains Runtime, just like the main IDE is using. See https://intellij-support.jetbrains.com/hc/articles/206544879. You can specify it in the run/debug configuration (JRE field).

1
Comment actions Permalink

Thank you Serge for your quick response and your help. Everything is functioning properly now.

0
Comment actions Permalink

Hello again Serge, 

Unfortunately, I'm running into some problems again.  After following the instructions on the link that you sent me, and rebuilding IJ IDEA, for some strange reason, the rebuild is successful, but it opens in CommandLineWrapper with the entire main mac menu bar being completely unresponsive.  Again, once loaded, the UI elements work, i.e., buttons, contextual menus, etc...  I understand what the CommandLineWrapper is for.  However, I don't understand after doing a few rebuilds, why it loads the IDE in CommandLIneWrapper, which is totally unresponsive.  

Do you think that since I'm running on a mac version 10.14.4, that there's some glitch with the top-level menu bar ?  Evidently, the command line args are too long, and that's triggering the wrapper rt to fire, but I'm not sure why, considering when I first presented this issue to you, I was able to switch to the JB runtime, and everything seemed to work properly until I did a couple rebuilds, then it seemed like it reverted back to the non-JB runtime, and back to Oracle.  I'm baffled by this.  Could this be a build config problem ?  Like I was saying, the build  builds successfully.  Is this possibly a Mac thing ?  Have you ever done a build on a recent Mac ?  There's not much info available on the internet.  This is extremely frustrating.   Again, here's some build info:

---------------------------------------------------------------------------------------------------------------------------------------------------

IntelliJ IDEA 2019.2 Snapshot (Community Edition)
Build #IC-192.SNAPSHOT, built on 03:37, April 6, 2019
Runtime version: 1.8.0_191-b12 x86_64
VM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
macOS 10.14.4

0
Comment actions Permalink

> Runtime version: 1.8.0_191-b12 x86_64

That is the root case, you need to run using JetBrains Runtime: https://bintray.com/jetbrains/intellij-jdk/.

You can specify it in the Run/Debug configuration, JRE field.

1
Comment actions Permalink

Hello Serge,

Thank you again for pointing me in the right direction.  After downloading the latest JB Runtime and specifying it in the Run/Debug configuration, this is the build info that I'm getting now:

--------------------------------------------------------------------------------

IntelliJ IDEA 2019.2 Snapshot (Community Edition)
Build #IC-192.SNAPSHOT, built on 23:12, April 6, 2019
Runtime version: 1.8.0_202-release-1483-b37 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

--------------------------------------------------------------------------------

Also, upon loading, the first main menu item is still showing CommandLineWrapper, however, all menu options are responsive and functioning properly, and it seems to be staying that way even after successive rebuilds which is great !  

Thanks again,

Larry

0

Please sign in to leave a comment.