Viewing javadocs, links always open external source in browser instead of local source in IDE


in Eclipse, I could click through references from one javadoc element to another.
When documentation referred to another entry (for example a method from the superclass in order to get more information), I could click that part and Eclipse would just follow it to open the corresponding javadoc.
At the moment this doesn't work in Intellij, it just always opens the browser.
Is there a way to configure this behaviour?
I was unable to find a setting for it and the documentation didn't give me any hint.

Thank you!


Comment actions Permalink

What kind of links are you referring to? URLs?

Can you provide an example?

Comment actions Permalink

Thanks for your answer.

An example from Android:

* Returns the last {@link #setSystemUiVisibility(int)} that this view has requested.
* @return  Bitwise-or of flags {@link #SYSTEM_UI_FLAG_LOW_PROFILE},
public int getSystemUiVisibility() {
    return mSystemUiVisibility;

Viewing documentation of getSystemUiVisibility and then clicking on any of those links, opens inside the browser.
This happens too quickly to be completely sure, but I think IntelliJ concurrently jumps to that part of the doc too, so it does work, it's only unusable because once the browser opens, the quick doc window is already gone.

It's very easily possible that I just messed up the config, somehow I can't imagine that this is default behaviour.
I just couldn't find anything in the documentation to change that.

Looking up external sources via external browser is nice, it's just very inconvenient if the source is available locally and could be displayed inside the IDE.

Comment actions Permalink

It's a known bug specific to Android SDK, please vote for .

Comment actions Permalink

Thanks Serge,

I hope it will be resolved soon.

Comment actions Permalink

I have just noticed that this issue is from 2012.
It seems though that Android Studio is uneffected.
Does this mean it will be fixed in IntelliJ as well?

Comment actions Permalink

Hope so, it was assigned to a wrong developer, so there was no progress. Once it's assigned to a new developer, it should not take that long to fix.

Comment actions Permalink

My IntelliJ IDEA does this now... 2018.1.4

I still can't find an option to disable the browser from ever be opened.

The class/docs are available locally. It link to a 404 in my browser...


Please sign in to leave a comment.