Upgraded IntelliJ - lost configuration

I just downloaded the latest IntelliJ (#IC-141.713.2) and ran it. Then I ran my old version (#IC-141.178.9) again. When I started the old one up, I got messages about not being able to find my color schemes in dialog boxes.  Here's the log entry:

2015-05-01 13:57:52,357 [   4295]   INFO - ions.SchemesManagerFactoryImpl - Cannot read scheme Andrew.icls  from '$ROOT_CONFIG$/colors': Unsupported color scheme version: 141
java.lang.IllegalStateException: Unsupported color scheme version: 141
        at com.intellij.openapi.editor.colors.impl.AbstractColorsScheme.readScheme(AbstractColorsScheme.java:283)
        at com.intellij.openapi.editor.colors.impl.AbstractColorsScheme.readExternal(AbstractColorsScheme.java:263)
...

Then I ran the new version again, and there were no warning messages, but my schemes were still gone! There were some other errors in the logs; not sure if they are relevant:

2015-05-01 14:00:01,495 [  34559]   INFO - vaFunctionalExpressionSearcher - #files: 67
2015-05-01 14:00:03,489 [  36553]  ERROR - ferenceCompatibilityConstraint - Assertion failed
java.lang.Throwable
        at com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:144)
        at com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:153)
        at com.intellij.psi.impl.source.resolve.graphInference.constraints.PsiMethodReferenceCompatibilityConstraint.getSubstitutor(PsiMethodReferenceCompatibilityConstraint.java:227)
        at com.intellij.psi.impl.source.resolve.graphInference.constraints.PsiMethodReferenceCompatibilityConstraint.reduce(PsiMethodReferenceCompatibilityConstraint.java:160)
        at com.intellij.psi.impl.source.resolve.graphInference.InferenceSession.reduceConstraints(InferenceSession.java:751)
        at com.intellij.psi.impl.source.resolve.graphInference.InferenceSession.repeatInferencePhases(InferenceSession.java:732)
        at com.intellij.psi.impl.source.resolve.graphInference.InferenceSession.processOneConstraint(InferenceSession.java:1150)
...

So then I went into my .IdeaIC14/config directory, and there was no colors directory! It was completely gone (it wasn't empty - it didn't exist). My keymap customizations survived.

Obviously, I should have been backing up my config directory, but I'm so frustrated that all my customizations are gone. I know there's nothing to be done to get them back, but I thought you might like to know in case there's something you could fix for the next person to try this.

Andrew

3 comments
Comment actions Permalink

Just happened again. I removed a plugin and clicked "Restart" and when it restarted, I got the same can't-find-scheme errors and my colors directory was again deleted! I think I'm going back to 141.178.9.

Andrew

0
Comment actions Permalink

It's totally repeatable. Fire up 141.713.2, go to Settings -> Editor -> Colors and Fonts. Save a new scheme. See that it's there. Then fire up 141.178.9. It will complain about it not being there and then delete the directory. I don't think I have permission to file a bug, but will if somebody lets me know where to do it.

0
Comment actions Permalink

IDEA settings are not backwards compatible. Please don't run an old IDEA version with the color scheme that was converted for the new version format.

We have a bug logged at https://youtrack.jetbrains.com/issue/IDEA-139183 , please follow it for updates.

0

Please sign in to leave a comment.