Terminal seems to be disabled in 14.1

Just installed the new 14.1

Terminal opens without prompt, it's really looks like it's been dsabled.

Any way to ressurect it? I'm on Linux Mint 17 xfce

thanks,
john

9 comments
Comment actions Permalink

I will have to clean reinstall 14.1 (I was reusing older 14.0.1 config/system via idea.properties)

the way it is right now is pretty much unstable, I was attempting to restart and idea just completely froze.

Some stacktrace excerpts from log, if it helps:

[  69794]  ERROR - on.console.RunIdeConsoleAction - null
java.lang.ExceptionInInitializerError
 at org.codehaus.groovy.jsr223.GroovyScriptEngineFactory.getLanguageVersion(GroovyScriptEngineFactory.java:68)
 at com.intellij.execution.console.RunIdeConsoleAction$Engines$1.call(RunIdeConsoleAction.java:91)
 at com.intellij.execution.console.RunIdeConsoleAction$Engines$1.call(RunIdeConsoleAction.java:83)
 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
 at java.lang.Thread.run(Thread.java:744)
 at org.jetbrains.ide.PooledThreadExecutor$1$1.run(PooledThreadExecutor.java:56)
Caused by: groovy.lang.GroovyRuntimeException: Conflicting module versions. Module [groovy-all is loaded in version 2.3.9 and you are trying to load version 2.2.1
 at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl$DefaultModuleListener.onModule(MetaClassRegistryImpl.java:509)
 at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromProperties(ExtensionModuleScanner.java:77)
 at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromMetaInf(ExtensionModuleScanner.java:71)
 at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModules(ExtensionModuleScanner.java:53)
 at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:110)
 at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:71)
 at groovy.lang.GroovySystem.<clinit>(GroovySystem.java:33)
 ... 8 more
[  69795]  ERROR - on.console.RunIdeConsoleAction - IntelliJ IDEA 14.1  Build #IU-141.177.4
[  69795]  ERROR - on.console.RunIdeConsoleAction - JDK: 1.7.0_45
[  69795]  ERROR - on.console.RunIdeConsoleAction - VM: Java HotSpot(TM) 64-Bit Server VM
[  69795]  ERROR - on.console.RunIdeConsoleAction - Vendor: Oracle Corporation
[  69795]  ERROR - on.console.RunIdeConsoleAction - OS: Linux
[  69795]  ERROR - on.console.RunIdeConsoleAction - Last Action: About
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor
exec_pty(71): returning due to error: Bad file descriptor

..which is strange 'cause i don't have the plugin enabled.



Also, when idea crashed this is what i see in the log:



exec_pty(71): returning due to error: Bad file descriptor
Exception in thread "PtyProcess Reaper" java.lang.ClassFormatError: Incompatible magic value 1347093252 in class file com/sun/jna/Function$PointerArray
 at java.lang.ClassLoader.defineClass1(Native Method)
 at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
 at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
 at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:259)
 at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:255)
 at com.intellij.util.lang.UrlClassLoader.findClass(UrlClassLoader.java:216)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
 at com.sun.jna.Function.invoke(Function.java:303)
 at com.sun.jna.Library$Handler.invoke(Library.java:216)
 at com.sun.proxy.$Proxy123.exec_pty(Unknown Source)
 at com.pty4j.unix.NativePtyExecutor.execPty(NativePtyExecutor.java:18)
 at com.pty4j.unix.PtyHelpers.execPty(PtyHelpers.java:401)
 at com.pty4j.unix.UnixPtyProcess.exec(UnixPtyProcess.java:306)
 at com.pty4j.unix.UnixPtyProcess$Reaper.execute(UnixPtyProcess.java:358)
 at com.pty4j.unix.UnixPtyProcess$Reaper.run(UnixPtyProcess.java:364)



Will let you know how it works after reinstall
0
Comment actions Permalink

Please find idea's log attached.

just to let you know that this is the bare idea configuration after new install, one project setup, I have to remove most of the plugins that come enabled by default.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

This log has no errors related to the terminal problem. Do you still have it?

0
Comment actions Permalink

Indeed. I find it strange that no one seem to have it though. Can anyone test this release in an ubuntu flavour with respect to the terminal problem?

0
Comment actions Permalink

I have exactly the same issue!

Mint 17.1 Cinnamon 64 bit
Cinammon Version : 2.4.6
Linux Kernel : 3.3.0-48-generic

Everything was working fine in 14.0 When I updated to 14.1 the terminal stop to work!

Hope you can resolve that fast

Thanks

0
Comment actions Permalink

Not 14.1 but in a previous update the colors got changed for the terminal and conflicted with my existing colors. The terminal was just blank white and I thought it wasn't working (it completely looked disabled). I think I eventually clicked inside the terminal and did a CTRL+A (select all) and was able to see the white text (now with a blue selection).

0
Comment actions Permalink

It's been solved here by cleanly reinstalling idea 14.1, different directory, no import of previous idea config.

0
Comment actions Permalink

Thanks John,

I fixed it on the same way!

delete everything and .intellij folder and reinstall!

I'm fine now!

0

Please sign in to leave a comment.