22 comments
Comment actions Permalink

There is no ability to "stick" floating window.

0
Comment actions Permalink

you can only dock it back to the debug toolwindow.

0
Comment actions Permalink

Hmm. How can I dock it back? I can't find any way.

1
Comment actions Permalink

You need to drag the watches tab itself (where icon with googles located) from the detached window to the container
It may be easier to restore layout (there is a button for that on the left toolbar in debugger toolwindow)

5
Comment actions Permalink

I have a Watches floating window, not a tab. I had tried to hover it over the Debug tab, but nothing happens.

0
Comment actions Permalink

Isn't there a tab inside the floating window?

1
Comment actions Permalink

Ah, I see what you mean. That's... very far from intuitive.
Thanks for helping.

2
Comment actions Permalink

Andrei, I know exactly what you mean, it was frustrating the first few times, then the last time I just gave up trying to remember as it wouldn't 'click' back into place !

The developers need to understand that (1) if it was easy dragging it OUT, it should be easy reversing that and (2) with the horrible design of laptop touchpads where you can accidentally touch the pad multiple points and suddenly you see a runaway debug window and we spend time moving it out of the way

The last few times I had to have help from others - the Restore button should be in a prime and intuitive spot. AND in the runaway window. Please.

0
Comment actions Permalink

I just ran into this issue myself with the console tab.  I'm dragging the window around trying to dock with no luck.  No menu items help.  Restore layout didn't help.  I just dealt with it until I read this article.  Agree that this isn't intuitive (even though it makes sense logically that if you drag out using the tab it makes sense to drag in using the tab).  However, most IDE's I've used let you drag in using the window.

Here's an image describing what should and should not be dragged:

Grab the Tab (not the Window title bar) and drag it around in IntelliJ.  When it gets to a place where it can be docked, you'll see a light blue shading.

2
Comment actions Permalink

This is very frustrating. Second time this happens, found this thread, didn't really help. Little icon to "Restore Layout" didn't dock the window back. Dragging windows and tabs (yuck) didn't work either. In the windows menu, "Docked mode" under "Active Tool Window" was disabled (probably for some good reason).

The only solution was to select in the Window menu the option Restore Default Layout. But I have to say, not very intuitive. Sometimes I use tiling and want switch to floating, sometimes not. Restoring layout every time seems very odd...

2
Comment actions Permalink

> The only solution was to select in the Window menu the option Restore Default Layout. But I have to say, not very intuitive.

Thanks, that fixed it for me! For the next poor soul:

5
Comment actions Permalink

Shift + F12 helped! Thanks Markus Fischer.

But as other fellows said, it's really frustrating and other solutions wouldn't work in Deepin Desktop environment.

0
Comment actions Permalink

Just uncheck floating mode and windows mode. The window goes immediately back to docked mode.

3
Comment actions Permalink

"Just uncheck floating mode and windows mode."

That is exactly what got broken since the new version 2018.1 (still not working in 2018.1.4.) with relation to the Debug tool window. This tool window is now broken and once undocked, it does not want to get docked back. Also the Alt+5 shortcut to hide this window is not working anymore. Alt+5 works to open it though.

1
Comment actions Permalink

> You have no permissions to view this page

☹️

0
Comment actions Permalink

Switched permissions on https://youtrack.jetbrains.com/issue/IDEA-187306

I have tried to reproduce the problem on IU-181.5087.20, looks like the problem is fixed, could you please check on this build?

0
Comment actions Permalink

I've encountered the problem when I turned on the "Floating Mode" on. I couldn't go back. "Pinned Mode" and "Docked Mode" disappeared from the dropdown menu. It turned out, that I simply had to click (or rather uncheck) "Floating Mode" again. Everything went back to normal again.

 

0
Comment actions Permalink

Seriously, it does not work. When selecting the mode to docked it keeps floating.

0
Comment actions Permalink

Jose, what worked for me was clicking on the (already checked) 'Floating Mode' item.  In other words, to float the window, click on 'Floating Mode'.  To dock the window, click on 'Floating Mode' again.  I'm using v2018.3, but I don't think this part of the UI has changed in a while.

'Docked Mode' is in the menu when it's docked, but disappears when it's floating.

2
Comment actions Permalink

"Just uncheck floating mode and windows mode. "

 

This works at least in my version (PHPstorm 2017.3)

0

Please sign in to leave a comment.