Find usages not working (Alt+F7)!

Answered

Hello there.
I have been using IntelliJ for 4 year.
I have 10.5.2 U.
My problem for some reason find usages and ispections have stopped working.
My classes get highlighted for deletion and when I try to find usages of variables that are used many times at the same class it finds nothing.
Things I tried:
1. Recreate the project/modules
2. Reset ide settings to default
3. Use EAP 110.187
4. Removed some external plugins

What is strange though is if I use the text search (crtl+shift+F) it finds all of them in all the classes.?:|

Any hints?

12 comments

Try File | Invalidate caches

On 11/2/2011 9:18 PM, Zisis Pontikas wrote:

Hello there.
I have been using IntelliJ for 4 year.
I have 10.5.2 U.
My problem for some reason find usages and ispections have stopped working.
My classes get highlighted for deletion and when I try to find usages of variables that are used many times at the same class it finds nothing.
Things I tried:
1. Recreate the project/modules
2. Reset ide settings to default
3. Use EAP 110.187

>

Any hints?

>

---
Original message URL: http://devnet.jetbrains.net/message/5364062#5364062


4

Thanks!
That was it.
Now why didn't I do that earlier?
Most of the time it the caches' that have a problem and a simple invalidation will fix it :D

0

Thanks for posting this (I know it was a long time ago) but it was the fix I needed and it was driving me nuts.

Thanks again.

Chris

0

Please attach zipped idea logs for us to do cache inva
lidation automatically


0

Err... do what?

I solved my problem via the menu.  Are you saying there's a different/automatic thing that can be set up?

0

I had the same problem, and invalidating the caches fixed it!

Attaching Idea logs as previously requested, in case that will still be of help to the developers.



Attachment(s):
IdeaLogs.zip
0

New geforce experience registered some shortcuts including ALT+F7, I found it using ( HotKeysList http://www.nirsoft.net/utils/hot_keys_list.html ) and after some investigation I found that it is related to the share feature from it (which it is enabled with alt+z but registers some shortcuts globally). You can disable it in the configuration, or reconfigure shortcuts after pressing alt+z. Hope it helps someone :) as I tried the invalidating cache and it didn't work.

13

The tip about the Geforce experience did it for me !  (as invalidating cached didn't help either)

 

0

It was GeForce Experience's fault: 

5

Thank you! Geforce Experience was the culprit all along!

0

Esdras Lopez, you relieved me. Thank you.

0

Yes I had the exact same problem with GeForce Experience. It is easy to test if it is running by trying shortcut Alt+Z to open it.

0

Please sign in to leave a comment.