IntelliJ IDEA 13.1.2 run/debug buttons get disabled randomly

Answered

"randomly" or I can't identify a way to accurately reproduce the issue.  When I'm working, occasionally I'll hit the run or debug button with a specific configuration selected and that button (not both, just the one I pressed) will become grayed out (it typically does while its in the middle of compiling), but then the application doesn't run at all.  The compilation seems to finish just fine, and there are no errors anywhere in the Messages window.  The run or debug button remains grayed out and currently my solution is to simply restart IntelliJ to get it back.

First, is this something I'm doing wrong? Or is actually a bug with IntelliJ? It seems more like the latter.

Second, are there any known work arounds? Does anyone else experience something similar?  A Google search revealed several other problems that are either in older versions, or similar but unrelated problems.

Thanks,
Marcus Johnson

7 comments

It sounds like IDEA-116630  Run/Debug button disabled sometimes after breaking make process. That issue was marked as fixed yesterday. It is marked as fixed in v14. It's possible they may back port it to 13.1.3. You may want to ask if that is the case on the ticket.


This is a long shot... as a temporary fix, try invalidating the IDEA caches (File > Invalidate Cache) and restart IDEA. When you reopen the project, IDEA will re-index it (a status is shown in the lower status bar to the right of center). Depending on the size of your project (and the number of dependencies), this can take anywhere from a second or two to several minutes. Once that is done, see if the issue continues to occur. Sometimes a fresh set of indexes can help solve some issues for a bit.

1

Hi,

Regarding the ticket, the issue looks similar, but in my case, the compile isn't halted, it completes successfully (as indicated by the Event Log).  However, depending on how the issue in the ticket was fixed, it might fix this issue too.

I went ahead and tried your suggestion.  I'll let you know if the issues occurs again.

0

I have the same problem with version 2016.1.2

0

Had the same problem on 2017.1.3, and it went away when removing Rust modules from my project. Maybe a bug in the Rust plugin?

1

Similar case: run button disabled while debug enabled on 2017.1.5 version

File > Invalidate Caches and restart solves problem for me

 

2

This issue is still not fixed?? I'm using the newest ULTIMATE version of IntelliJ! I've tried many times (even in my actual project, where IntelliJ is set as a mandatory IDE), but hey guys, I really do not understand all statements about how better IntelliJ is compared to Eclipse! Only a few things: tried to import a large project (gradle based) in IntelliJ and tried to execute just one JUnit test and after hours of trying things out it’s still not working (I can run it but not debug, well sometimes the debug button is clickable, but if I click on it just nothing happens - no warning, no error, just nothing!!!!)… in Eclipse it took me just (REALLY!!!) few clicks and everything worked out of the box!!!! GDM, Jetbrains, for a commercial product I expect at least the same quality as an open source IDE like Eclipse… I’m searching since hours to find why that silly debug button is disabled and of course I’ve tried every single tip found on the net and have also the newest version of IntelliJ and all plugins up-to-date, tried to re-import everything from scratch in fresh checked out folder etc., etc. etc. ... so I’m really fed up with your product and I'm going to switch back to Eclipse - even if the project leaders will complain!

0

Please sign in to leave a comment.