"enter" key not working anymore

I upgraded to Intellij 13 and my enter key has suddenly stopped working. It works in every other program.

Sort of brings productivity to a screeching halt.:)

Anyone else have this problem or even better a solution? I did install an update today so that might be the cause.

Thanks!

6 comments
Comment actions Permalink

shift + enter does work so I can use Intellij again but a single enter does nothing.

0
Comment actions Permalink

Hmmmmm, tab is not working either. Seeing as the forum isn't filling up with people having the same problem it's probably not the update that did it.

Hopefully someone can tell me what setting I accidentily (as I haven't fiddled with the settings in the days before the problem occured) flicked.

I bought the Ultimate 12 version and was doing the 30 day trial for the 13 when this occured. I read a post that said that 12 keys were disabled for the trial so I figured that was the problem. Just bought my upgrade and entered the new key but the problem persists.

0
Comment actions Permalink

Python plugin did an update, after restart everything worked again. Not sure if related, probably not but problem solved.

I rebooted and restarted before that also.

Back to work :)

0
Comment actions Permalink

I've had same issue with Rubymine since last year. It's only been once a day kind of thing. Lately, it's happening way too often.

I am on version 8.0 (build: 143.381)

0
Comment actions Permalink

Same problem here (IntelliJ Ce 2017.1.2 on Mac OS 10.12.4). Restart and reboot didn't help.

0
Comment actions Permalink

I had the same problem, but in fact it was a change I tried to do in the keymap.

Solution for me was to reset the keymap to defaults

0

Please sign in to leave a comment.