can not import theme setting with a normal user under Gentoo

Answered

hello,

i am using IntelliJ IDEA 2016.1.2
Build #IU-145.971, built on April 29, 2016
JRE: 1.8.0_91-b14 amd64
JVM: OpenJDK 64-Bit Server VM by Oracle Corporation, OS: Gentoo.

I am confused by a strange problem. when i use normal user to  run file| import settings to import a theme package which owner is this normal user , there is not any components in popup dialog, and event log has nothing.

but if i change user to root, the theme component will be there and it can be selected. After change theme for root,  i try to copy config directory of root to normal user's home directory, it works well.

and i install IDE by root in /opt/, and also try normal user to install into its own directory, but it still does not work. so how can i import theme with without root ? 

 

Thank you.

12 comments
Comment actions Permalink

Check the permissions in the IDE config folder: https://intellij-support.jetbrains.com/hc/articles/206544519 . You must be able to write files there from the user account that is running IDEA. If needed, change the owner of the folder using chown.

0
Comment actions Permalink

thanks for replying.

before posting  i have checked permissions of all config files, and confirm that they have right permissions for normal user that is running IDEA.

i copy root's config folder to the normal user, and change all files belonging to the normal user. but when i open IDEA to import same theme setting , it still have no components there. although it keep the color theme setting when i setup by root.

0
Comment actions Permalink

What exactly do you import and how?

0
Comment actions Permalink

A Color Scheme named "Ladies Night 2.jar",  by menu File | Import Settings with a normal account.

difference between a normal account and admin is if the following popup dialog named "Select Components Import" with a selectable Component. and the import file is own by normal account and located in my own folder.

normal account actions like following picture.path: /home/NormalUser/night.jar

0
Comment actions Permalink

Please share a sample file to reproduce.

0
Comment actions Permalink

https://mega.nz/#!rUED0ZRA!8ddnCkWWec6qe3l9q-au8A2U6zTZFpCg0qFXso3guU8 

i think this color plugin works well, because i tried it in another laptop which IDEA running with Archlinux's normal account.

BTW, i tried Ultimate and Community Version on current PC before. it both does not work. And check different shell environment and java env when IDEA bootup between admin and  normal, but it's almost same.

i appreciate your reply.

0
Comment actions Permalink

i checked the log file, but still find nothing may cause the problem.

log file: https://mega.nz/#!DB1xBC4Y!o-bzHoYOUzPm1-lcg9iCviK9yDiWUugOwoKFc2649NE 

i do like following to generate the log:

1. clean all log in config folder.

2. open IDEA, import setting with plugin, but still nothing in popup dialog, press OK to import.

3. IDEA ask me to restart to reload the new setting (nothing loaded)

so you can see the entire log between two IDE start that's all i do. are there any ways to let it print more verbose ?

0
Comment actions Permalink

Does it help if you temporary remove config directory for the normal user (https://intellij-support.jetbrains.com/hc/articles/206544519), start IDEA with all the defaults, and then try to import it again?

0
Comment actions Permalink

still not work. but i think i find the way to reproduce the problem.

1. under gentoo(maybe linux ?), mkdir by root in /home/<user>

2. useradd <user> -d /home/<user>, copy account config file to /home/<user>, like "find /etc/skel/ -exec cp -rf {} /home/<user>/ \;

3. chown <user> -R /home/<user> && chgrp <user> -R /home/<user>

4. change to <user> just added,  run idea

5. try to import settings.

on my PC, this way can reproduce every time. it seems Home direcotry created by command useradd -m will works well

0
Comment actions Permalink

You may want to submit a bug at https://youtrack.jetbrains.com/issues/IDEA with the exact steps to reproduce the problem.

0
Comment actions Permalink

thanks a lot. 

i create a issue IDEA-157407  for tracing this problem.

0

Please sign in to leave a comment.