idea.config.path is invalid

Hi,

I just started having an issue with my idea.config.path on my Windows 7 install running on my 64bit MabookPro under BootCamp. I have been using IDea for several months until most recently when I attempt to launch Idea I get an error prompt saying:

"Config path 'C:\Windows\System32\config\systemprofile\.IntelliJIdea11\config' is invalid. If you have modified the 'idea.config.path' property please make sure it is correct, otherwise please reinstall the IDE."

This was after a recent upgrade to Parallels 8 on my OS X partition and a recent install of Visual Studio Express 2012. I noted that VS 2012 created a restore point so I restored from the restore point in an attempt to fix Idea. Prior to the restore I tried to reinstall Idea multiple times and each time I get the error after restarting Idea. I also noted that I couldn't see a "C:\Windows\System32\config\systemprofile\.IntelliJIdea11\config" folder after each install and initial run of Idea. I also noted that I could run the 64bit binary just fine but I need the 32bit version in order to run the Django tools which are configured in a 32bit Python environment. I also tried changing the permissions of my systemprofile folder from read-only to writeable but still the .IntelliJIdea11 folder would not show after an install and run. This was all prior to restoring from the restore point. After the restore I noticed my function keys were not properly mapped requireing me to hold the Fn key to type F2. I've since rebooted into OSX and have reinstalled Parallels Tools. That seems to have fixed my function key issue and I now see the .IntelliJIdea11 folder after my latest install, however I still get the error prompt. I am about to try temporarily moving the folder (maybe running the 64bit binary creates a 64bit version of the configs?). I'm asking here for help because I don't know what else to do or how to change my "idea.config.path". (I used to remember the locations of the config folder values but so much has changed since version 6 when I was gung-ho.) Pleae help!

14 comments
Comment actions Permalink

I found the idea.config.path setting in idea.properties under idea.home\bin and I uncommented it to point to the user.home folder. I still got the error prompt so I tried "Run As Admin" which seems to get around the error prompt. Please help, I don't want to "run as admin" each time I launch. What have I broken? How can I fix it?

0
Comment actions Permalink

Thanks Serge!

I set my "idea.config.path" under $idea.home/bin to a hard-coded path for now. If I had more steam I would figure out how to hack and pass the %USERHOME% env var thru the configs but this will work for now. Thanks again!

0
Comment actions Permalink

I just noticed that when I run idea.bat from cmd.exe that I get errors indicating that the script monkey and pycharm plugins still use old plugin.path. I configured all paths in idea.properties replacing the ${user.home} with a hard coded path see my config.path & plugin.path in particular:

idea.config.path=C:/Users/Clifton/.IntelliJIdea/config
idea.plugins.path=C:/Users/Clifton/.IntelliJIdea/config/plugins

When I launch idea.bat I see:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Clifton>cd "C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.1.3\bin"

C:\Program Files (x86)\JetBrains\IntelliJ IDEA 11.1.3\bin>idea.bat
[   4922]  ERROR - ion.CopyScriptsOnStartupAction - Error copying scripts !
java.io.FileNotFoundException: C:\Windows\system32\config\systemprofile\scriptMo
nkey\js\global\gui.js (Access is denied)
        at java.io.FileOutputStream.open(Native Method)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:194)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:145)
        at com.intellij.openapi.util.io.FileUtil.openOutputStream(FileUtil.java:
707)
        at com.intellij.openapi.util.io.FileUtil.performCopy(FileUtil.java:664)
        at com.intellij.openapi.util.io.FileUtil.copy(FileUtil.java:656)
        at com.boxysystems.scriptmonkey.intellij.util.ScriptMonkeyFileUtil.copy(
ScriptMonkeyFileUtil.java:21)
        at com.boxysystems.scriptmonkey.intellij.util.ScriptMonkeyFileUtil.copyD
ir(ScriptMonkeyFileUtil.java:47)
        at com.boxysystems.scriptmonkey.intellij.util.ScriptMonkeyFileUtil.copyD
ir(ScriptMonkeyFileUtil.java:45)
        at com.boxysystems.scriptmonkey.intellij.util.ScriptMonkeyFileUtil.copyD
ir(ScriptMonkeyFileUtil.java:45)
        at com.boxysystems.scriptmonkey.intellij.util.ScriptMonkeyFileUtil.copyD
ir(ScriptMonkeyFileUtil.java:30)
        at com.boxysystems.scriptmonkey.intellij.action.CopyScriptsOnStartupActi
on.copyScripts(CopyScriptsOnStartupAction.java:53)
        at com.boxysystems.scriptmonkey.intellij.ScriptMonkeyApplicationComponen
t.initComponent(ScriptMonkeyApplicationComponent.java:49)
        at com.intellij.openapi.components.impl.ComponentManagerImpl.b(Component
ManagerImpl.java:216)
        at com.intellij.openapi.components.impl.ComponentManagerImpl.access$1100
(ComponentManagerImpl.java:54)
        at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentCo
nfigComponentAdapter$1.getComponentInstance(ComponentManagerImpl.java:643)
        at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentCo
nfigComponentAdapter.getComponentInstance(ComponentManagerImpl.java:578)
        at com.intellij.util.pico.DefaultPicoContainer.getLocalInstance(DefaultP
icoContainer.java:242)
        at com.intellij.util.pico.DefaultPicoContainer.getInstance(DefaultPicoCo
ntainer.java:229)
        at com.intellij.util.pico.DefaultPicoContainer.getComponentInstance(Defa
ultPicoContainer.java:211)
        at org.picocontainer.alternatives.AbstractDelegatingMutablePicoContainer
.getComponentInstance(AbstractDelegatingMutablePicoContainer.java:75)
        at com.intellij.openapi.components.impl.ComponentManagerImpl.createCompo
nent(ComponentManagerImpl.java:126)
        at com.intellij.openapi.application.impl.ApplicationImpl.createComponent
(ApplicationImpl.java:399)
        at com.intellij.openapi.components.impl.ComponentManagerImpl.a(Component
ManagerImpl.java:107)
        at com.intellij.openapi.components.impl.ComponentManagerImpl.initCompone
nts(ComponentManagerImpl.java:342)
        at com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load
(ApplicationStoreImpl.java:84)
        at com.intellij.openapi.application.impl.ApplicationImpl.load(Applicatio
nImpl.java:515)
        at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:206)
        at com.intellij.idea.MainImpl$3.run(MainImpl.java:194)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:646)
        at java.awt.EventQueue.access$000(EventQueue.java:84)
        at java.awt.EventQueue$1.run(EventQueue.java:607)
        at java.awt.EventQueue$1.run(EventQueue.java:605)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessCo
ntrolContext.java:87)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:616)
        at com.intellij.ide.IdeEventQueue.e(IdeEventQueue.java:699)
        at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:538)

        at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:420)
        at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:378)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThre
ad.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.
java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)

        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)

        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

0
Comment actions Permalink

Did you replace idea.system.path as well?

0
Comment actions Permalink

Yes, I updated all confi properties that pointed to user.home to use a hard-coded path. The problem is related to the JDK bug you mentioned earlier and it is more serious than I thought. I checked the source for the ScriptMonkey plugin and when defining its home folder it too references the "user.home" property which resolves to "C:\Windows\system32\config\systemprofile" on my machine. I while I can update the plugin source, recompile and reinstall, I suspect this to be an ongoing issue with everything related to Java. Is there an easier workaround that would place the change closer to the JVM? I'm thinking of wrapping or aliasing the java executables with executables of my own the update this property prior to invoking Java.
 
 
 
 
 
 
 
 

0
Comment actions Permalink

Do you mean that changing the value in the Windows registry doesn't persist?

0
Comment actions Permalink

I've filed issue #18 on the ScriptMonkey plugin adding more detail to what I'm seeing. I'll elaborate briefly here as well. I modified idea.exe.vmoptions and appended "-Duser.home=C:\Users\Clifton" which appears to correctly set the user.home property for the VM. (I verified this with the property window plugin). However, I still see the scriptmonkey error upon startup and the plugin itself is completely useless as any script throws errors. I'm concerned as to what impact I will see througout other parts of Idea with this issue. So far I've been coding mostly in Python and my other workarounds seem to be keeping things running. I don't want to change my registery for fear of disturbing or altering behavior in Visual Studio which I have yet to use. Please advise.

0
Comment actions Permalink

Sorry I missed your response Sergey. No, I haven't changed the value in the Windows registry as I am afraid to break Visual Studio. I imagine VS made this change for a reason, and from what I've read the flaw is in Java in that it should not be using that particular key to resolve user.home. I was trying a different approach, editing the vmoptions file read by Idea on startup. That appears to allow me to override the value of user.home but I'm not understanding why the mokey script plugin does not see the updated value. Is this a flaw in Idea or in Monkey script? Monkey script merely uses user.home to find its home folder.

0
Comment actions Permalink

Same error,my os is ubundu ,what do i do??

 

0
Comment actions Permalink

What do you mean by the same error? The one described above is Windows specific.

Please submit a new ticket with more details: https://intellij-support.jetbrains.com/hc/requests/new.

0
Comment actions Permalink

I have solution for this issue ..

idea.config.path on my Windows 7

 

step1

Open>cmd>rightclick>Runas administrator>cd C:\Program Files\JetBrains\PyCharm Community Edition 2019.1.1\bin

step 2

then run PyCharm.exe

Note :

every time you need to follow this process to start Pycharm.

this is the solution of this problem

0
Comment actions Permalink

second solution is:

solution for this problem after installation :-

Config path 'C:\Users\Mukund\.PyCharmCE2019.1\config' cannot be used by the IDE.

If you have modified the 'idea.config.path' property, please make sure it is correct,
otherwise please re-install the IDE.

 

Desktop >pycharm icon >Right click>run as administrator

 

  ENjoy PyCharm ..........!!!!!!!!!!!!!!!!!

0
Comment actions Permalink

It looks like you have file system permissions issue in C:\Users\Mukund\.PyCharmCE2019.1\ directory.

0

Please sign in to leave a comment.