IDEA 11 Download Fails

After purchasing an upgrade license, I tried downloading the IDEA 11 GA release using the automatic download start and manual download link here: http://www.jetbrains.com/idea/download/download_thanks.jsp

In Firefox 8.01, it gets to about 99% and fails.  Repeated the process. Same results.

Switched to Chrome. Same results.

Switched to IE 8. Same results. Here is a screenshot:

IDEA Download Fails.gif

Any alternatives for getting the file? (I'd prefer a Zip file with no JRE.)

jack

3 comments

Serge,

I read the page at the link you posted. Thanks for that.

I'd like to firstly note I'm not generally inclined to turn off my anti-virus when downloading EXE programs as I like to know they've been scanned before I execute them. However, per the advice in the article at the link you sent, I turned off real-time scanning on my installed ESET anti-virus (and for good measure, the firewall), but the download still failed under Firefox.

I recalled that I also had installed Windows Defender last year. So I opened it up, and turned off it real-time scanning. The download succeeded! Now here's the strange part...

I turned Windows Defender and ESET's real-time scanning back on and re-attempted the download. With all the security protection now turned on, the download again succeeded. I will never understand why this worked, but am glad it finally did.

I'd recommend JetBrains track how many downloads are started, but never complete. If a lot of people wanting to try IDEA can't download it, they may silently click away and never come back.

Also, I recommend offering a non-EXE download  (i.e. a Zip file) for those of us who don't need a bundled JRE. (I suspect this is probably 99% of existing IDEA users anyway.)

Thanks for your help.

jack

0

Replace .exe with .zip in the download link to get zipped download without JRE.


0

Please sign in to leave a comment.