Disconnected from the target VM

Answered

when launching my run config in debug mode with #3368,
this happens:

Disconnected from the target VM at '127.0.0.1:1333' using socket transport.

Process finished with exit code -1073741819

any idea what is wrong?

11 comments
Comment actions Permalink

I got this problem as well with IDEA v5.0.2 running on XP.

To be more specific, whenever I run Swing application, and change focus of any components using the keyboard (for example by pressing tab or enter) i get this message.

Debugging is impossible altogether - IDEA flies with "Process finished with exit code -1073741819" on the spot.

Help?

0
Comment actions Permalink

Michael Damberger <michael.damberger@t-online.de> wrote:

any idea what is wrong?


No, but if you are running Windows, you could try shared memory
transport (transport can be set in the settings dialog).

Best,

Dirk Dittert

0
Comment actions Permalink

Not Working too

 

0
Comment actions Permalink

Your app finishes without errors and the debugger is disconnected because the process is no longer running. This behavior is correct and by design.

0
Comment actions Permalink

I was able to run same spring boot application till couple of hours back. But now I do get error

Connected to the target VM, address: '127.0.0.1:62705', transport: 'socket'
log4j:WARN No appenders could be found for logger (org.springframework.web.context.support.StandardServletEnvironment).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

. ____ _ __ _ _
/\\ / ___'_ __ _ _(_)_ __ __ _ \ \ \ \
( ( )\___ | '_ | '_| | '_ \/ _` | \ \ \ \
\\/ ___)| |_)| | | | | || (_| | ) ) ) )
' |____| .__|_| |_|_| |_\__, | / / / /
=========|_|==============|___/=/_/_/_/
:: Spring Boot :: (v1.5.15.RELEASE)

Disconnected from the target VM, address: '127.0.0.1:62705', transport: 'socket'

Process finished with exit code 1

 

what is meaning of this error and how to resolve it. I gone thorugh multiple portals in search of resolution but did not get any promising solutions

0
Comment actions Permalink

Try running the app from the terminal and see if it works. It could be a problem with your code and the app may exit because of some error that is not related to IntelliJ IDEA.

0
Comment actions Permalink

Thanks Serge Baranov  for commenting on this.

I can not run this application on terminal as application has not target jar (broken due to some reason) to run but having classes with lot of dependencies referring from /.m2/repositories.

I am in search of what is reason of this error so that accordingly I can solve root issue.

0
Comment actions Permalink

You can try running with:

mvn spring-boot:run
0
Comment actions Permalink

same problem   and  I tried running the app from the terminal . it works.

0
Comment actions Permalink

@271636872

Do you have an antivirus installed? Maybe Windows defender? Try to add IntelliJ IDEA to the exclusions list. 

Try to restart your computer also. 

0
Comment actions Permalink

Thanks Konstantin Annikov .

I just restart my computer and Try running the app from the Idea. it works , I don't know what changed.

0

Please sign in to leave a comment.