Could not save application settings error

After IJ auto-indexes a moderately sized codebase - maybe 250K lines  - i'm seeing following error.  I'm not sure this has to do directly with the indexing, but seems likely the memory requirements have an effect.

the message box says "Could not save application settings: java.lang.RuntimeException: com.intllij.util.io.MappingFailedException: Mapping failed: <homedir>\.IntelliJIdea10\system\caches\names.dat.keystream, position-0, length-10485760



Attachment(s):
IJCouldNotSaveAppSettings.JPG
4 comments
Comment actions Permalink

Hello Stephen,

The "mapping failed" exception appears when you set the -Xmx to an overly
large value, and IDEA runs out of virtual address space for mapping memory-mapped
files. It can be fixed by reducing the -Xmx value or by running IDEA under
a 64-bit JDK.

After IJ auto-indexes a moderately sized codebase - maybe 250K lines
- i'm seeing following error.  I'm not sure this has to do directly
with the indexing, but seems likely the memory requirements have an
effect.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

thx for the reply Dmitry.  I'm running under 64-bit windows 2003 server.      here are the settings (very conservative actually).   Note this machine has 12GB physical ram and hundreds gb's free disk space

C:\ij10\bin>cat idea.exe.vmoptions
-Xms768m
-Xmx1024m
-XX:MaxPermSize=392m
-ea

0
Comment actions Permalink

You are running under 32-bit JVM and hit 2GB address space limit for 32-bit processes. Lower heap size to 500-700m or run IDEA under 64-bit JDK: ftp://ftp.intellij.net/pub/.idea/idea64.zip.

0
Comment actions Permalink

Hello Stephen,

The amount of physical RAM doesn't matter - the virtual address space for
a 32-bit Java application is just 4G. On such a configuration, I'd recommend
running under a 64-bit JDK.

thx for the reply Dmitry.  I'm running under 64-bit windows 2003
server.      here are the settings (very conservative actually).
Note this machine has 12GB physical ram and hundreds gb's free disk
space

C:\ij10\bin>cat idea.exe.vmoptions
-Xms768m
-Xmx1024m
-XX:MaxPermSize=392m
-ea
---
Original message URL:
http://devnet.jetbrains.net/message/5283323#5283323


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.