How to pause/kill background tasks

Answered

i had my status bar turned off. turned it on and found I have 22  background tasks running. I'd like to selectively kill most of them.

thanks!

30 comments
Comment actions Permalink

Hi Stephen,

You can click on progress bar located at at the status bar - that causes IDEA to show a dialog with all background tasks active at the moment. It also provides ability to stop cancelable tasks.

Regards, Denis

-1
Comment actions Permalink

The dialog lists the running tasks but does not have any actionable items available.

1
Comment actions Permalink

There is a small round 'cancel' button for cancelable tasks (check screenshot below). Please provide screenshot with your tasks if you still experience problems with them.

cancel-background-task.png

-1
Comment actions Permalink

None of the tasks had that circle.  I killed IJ.  Many of the tasks were related to subversion - the client stopped working. I will post if I accidentally attempt to use IJ  for submission to svn again.

1
Comment actions Permalink

javadba wrote:

None of the tasks had that circle.  I killed IJ.  Many of the tasks were related to subversion - the client stopped working. I will post if I accidentally attempt to use IJ  for submission to svn again.

It would be nice to get a thread dump as well then in order to see where the threads are stuck.

0
Comment actions Permalink

I've had a few issues with the svn processes running in the background if I start Intellij without connecting to our corporate VPN. Our SVN server is only accessible when connected to the VPN and that causes Intellij some grief during startup. It's okay if I disconnect after Intellij is started. I looked for an offline mode but couldn't find anything similar to the maven offline switch for svn.

Grant

0
Comment actions Permalink

which version of intellij are you using? i had quite a few endless vcs background tasks up to 9.0

0
Comment actions Permalink

I'm on the latest version of IntelliJ Ultimate, 9.02. I also have the latest EAP installed, both on OS X. I've had some occasional difficulty with Intellij SVN and Maven integration. My primary SVN and Maven servers are behind a firewall so VPN access is required. I suspect Intellij is trying to connect on startup which is what I'd like to disable and make it more of an on-demand connection. Startup when I'm connected to the VPN is considerably faster than when I'm disconnected. In both cases Intellij will initialize but the time difference is noticeable.

Grant

0
Comment actions Permalink

I am using WebStorm 2016.1.1, and I don't see small round 'cancel' button either...

The 'updateing Indices' is very annoying, I also want to know how to stop/kill it which slows down my computer a lot...

1
Comment actions Permalink

This problem still exists. There's no option to kill background processes that misbehave.

OSX Current.

1
Comment actions Permalink

+1

same problem on subversion local changes

hangs in updating

macOS Sierra

0
Comment actions Permalink

+1

Same problem with git stat plugin "auto fetching"

 

0
Comment actions Permalink

PyCharm 2016.3.2
Build #PY-163.10154.50, built on December 28, 2016
JRE: 1.8.0_112-release-408-b6 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

MacOS SIerra

0
Comment actions Permalink

Oh, come on. I face this issue for many years in all IntelliJ idea versions on all of my machines and finally decided to find the issue for that.

Turns out this issue is being successfully ignored since 2010! Wow.

I will keep you posted then!

 

2017.2.2 (see screenshot)

$ java -version
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)
Ubuntu 16.04.3 LTS

It definitely happens because of VPN connection. The thing is that everything else works fine.

 

1
Comment actions Permalink

First day with Pycharm.

Something stuck connecting to the local vagrant host. Connecting 127.0.0.1 ...

I do see the X to stop the background task. When I click it: Stopping ...

So one solution is to quit. Do you want to kill background processes and quit? Well, I'd rather just kill background tasks and not quit, but since that's my only option, fine.

0
Comment actions Permalink

some problem here! 

0
Comment actions Permalink

You can try this. run `jps` to found the task PID, then kill it. It's work for me. : )

0
Comment actions Permalink

I too can confirm and condemn this misbehavior.

  • PHPStorm 2017.2.1
  • Windows 10

Just implement a force kill/cancel and I am happy.

0
Comment actions Permalink

2019 calling in. Nine years of this issue, then?

I often forget that I need my VPN to be connected in order for npm installs to succeed, so here I am now, staring down this never-finishing background process that I can't manually terminate.

  • Webstorm 2018.2.4
  • macOS Mojave 10.14.1

0
Comment actions Permalink

Hello
I am having the same issue...
So many years and the issue still remains.. Disappointing!

0
Comment actions Permalink

Same problem here

0
Comment actions Permalink

Same issue here. I have a background task which I try to kill with the X. But once I click the X, the task fails to die and the X disappears from the popup (see below). Only way to kill it to restart Intelij, which I find myself having to do all the time. Version 2019.1.3 running on Ubuntu 64

1
Comment actions Permalink

Please try 2019.2.1 release. If the issue persists, report it at https://youtrack.jetbrains.com/issues/IDEA with the logs and the thread dump taken via jstack attached:
https://intellij-support.jetbrains.com/hc/articles/207241085
https://intellij-support.jetbrains.com/hc/articles/206544899 .

0
Comment actions Permalink

lol wow this is still a problem 10 years later kthx guys

0
Comment actions Permalink

Yes, same problem with a later version (idea-IC-192.6262.58). I can't post the log as it contains code/proprietary information of my company. Anyway, the only solution is to kill and restart intellij whenever it happens (1-2 times a day in my case). Not big enough of a deal to stop using intellij as it has other advantages, but it forces me to use another IDE in parallel.

0
Comment actions Permalink

I'm seeing the same issue on IU-193.6015.39 - the only solution I've found is to kill IntelliJ. This seems to happen during DB operations that are blocked by the server, e.g. dropping a table in IntelliJ whilst a completely different OS process holds an open session into the database. Once the blocking session is killed, IntelliJ has no way to cancel the task that is being blocked.

Regarding the bug DB - there appears to be a few unanswered tickets related to this:

https://youtrack.jetbrains.com/issue/IDEA-187705

https://youtrack.jetbrains.com/issue/IDEA-222626

0
Comment actions Permalink

The Maven issue should be obsolete now - we will double check this. For database problem, please follow created https://youtrack.jetbrains.com/issue/DBE-10090 issue. Thank you.

0
Comment actions Permalink

Same problem with PyCharm when try to stop a deployment process get stuck.

0

Please sign in to leave a comment.