IntelliJ stealing focus

Answered

Hi,
I was typing a message in these forums and had IntelliJ 8.1 starting up in the background (latest eap build, but happens with 8.0.1 as well.).

I grabbed the focus at least 3 times, each time I alt+tabbed back to Firefox. This way Idea stole a part of my typed text, which messed up the source code of the restored edit window.

I'm seeing this behaviour now for quite a long time and it makes IntelliJ the application with the most annoying startup behavioiur on computer.It prevents me from using the startup time for something else.

Isn't it possible to fix this somehow?

Linux (Ubuntu 8.10), Java 1.6u10, IntelliJ 8 build #9618, gnome window manager.

Thanks a lot.
Wallaby

21 comments
Comment actions Permalink

Wallaby,

I know it doesn't help much, but this appears to be issolated to Linux (and possibly issolated to Debian based distros), Some JIRA's on it (and related focus stealing):

http://www.jetbrains.net/jira/browse/IDEADEV-21715
http://www.jetbrains.net/jira/browse/IDEA-15078
http://www.jetbrains.net/jira/browse/IDEADEV-420

0
Comment actions Permalink

Windows does still have its share of Focus issues here are a few (Search for: Focus ALT+TAB):
http://www.jetbrains.net/jira/browse/IDEABKL-5180
http://www.jetbrains.net/jira/browse/IDEA-17359


I also believe focus issues could be causing the poor ability of IJ to detect file changes on windows.

0
Comment actions Permalink

I'm using it on Linux, Ubuntu 9.04.

It steals focus when you debug an application while that start up too. Maybe it's whenever a debug message appears in the console.

It's very annoying to try to read something in firefox during that time.

I saw that letting intellij use the java 1.5 runtime avoids some of this problem? How can I do that? (making it use 1.5)

0
Comment actions Permalink

I'm getting this on Max OS X 10.6 with 9.0 Beta, when I start a long-running task such as a large ant build and switch to another application IntelliJ will steal focus when the task completes and moves forward to become the window behind the currently active one.

It's incredibly annoying, especially when I'm working in another app with multiple windows open.

0
Comment actions Permalink

It's still a problem with IDEA 9.0.2
Linux 2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

0
Comment actions Permalink

Still having this Problem to this day

0
Comment actions Permalink

This is really annoying. It happens to me regularly. Is there a fix?

0
Comment actions Permalink

We've been working intensively on OS focus issues lately. The changes are quite noticeable and are being tested now. It is aimed to solve many focus problems. If all goes well it will appear in nearest versions.

You can follow these issues for the status updates: https://youtrack.jetbrains.com/issue/IDEA-107264https://youtrack.jetbrains.com/issue/IDEA-106716

Also you could try 2018.1 EAP version with the `suppress.focus.stealing=true` option set via Help | Edit Custom Properties action (as advised by developer).

0
Comment actions Permalink

10 years later and the problem still exists, is there a counter effect to make the `suppress.focus.stealing=true` default? I haven't tested yet but this behavior must be default, and so the "Background Tasks" window that is "always on top" over other windows without I putting it there, this I think could be a feature, but optional. I'm using manjaro linux and facing this problems. 

0
Comment actions Permalink

I've got this weird mix of settings that on one hand prevents focus stealing, but on the other hand has this annoying side effect of making windows suddenly jump away from focus. This happens for instance when a plugin update happens in a window, or when I open an existing project in a new window.

I would love for there to be a concrete fix to simply preventing the IDE from stealing focus.

0
Comment actions Permalink

Hello,

> is there a counter effect to make the `suppress.focus.stealing=true` default?

This option was enabled, but on Linux it caused more problems than it fixed, so recently we made it disabled by default (does not concern macOS and Windows).

> “Background Tasks” window that is “always on top” over other windows

This is a known issue. Please, vote: https://youtrack.jetbrains.com/issue/IDEA-189048

> windows suddenly jump away from focus

Focus issues on IDE startup are covered in tickets linked to the following meta-issue: https://youtrack.jetbrains.com/issue/IDEA-208970

Please, check if your problem is presented among the linked issues. In case it is not, please, file a new issue, and describe steps to reproduce. Focus issues are different and usually specific for a particular window manager, so having them separated will give us a clear vision and speed up fixing.

1
Comment actions Permalink

Jisrael,

> This happens for instance when a plugin update happens in a window

Could you please describe in more details, at what point of the update does this happen?
What OS and window manager do you use? Also, please, provide information from "Help | About" section.

0
Comment actions Permalink

I'm using IntelliJ Ultimate 2019.1.3 on Kubuntu 16.04 (KDE)
JRE 1.8.0-202-release-1483-b58

Actually I think what I should have said is that it drops focus to the back behind other open projects when I choose some popup asking if I want to enable things like "detected python". 

0
Comment actions Permalink

Also, I am currently using the following idea.properties

suppress.focus.stealing=true

idea.popup.weight=medium

0
Comment actions Permalink

Jisrael,

Thanks for details. Please, try using JBR 11 as boot JDK. Download the latest build: https://bintray.com/jetbrains/intellij-jbr/download_file?file_path=jbr-11_0_3-linux-x64-b304.2.tar.gz

See this instruction to switch: https://www.jetbrains.com/help/idea/switching-boot-jdk.html

0
Comment actions Permalink

Thanks for that suggestion. I have just updated it and can report back after some usage time. But is the recommendation to keep or remove the 2 settings that I had posted, in addition to this update?

0
Comment actions Permalink

It is recommended to set "idea.popup.weight" to "medium" when you have Focus follows mouse enabled with Auto Raise. Otherwise it should be set to "heavy".

0
Comment actions Permalink

@Arseniy I just found a case where the project window focus drops behind another one, even with the updated JBR 11. I went to the System Settings and made a change to "Synchronize files on frame or editor tab activiation", and when I hit ok, the project window dropped down and another project window was now on top.

0
Comment actions Permalink

Jisrael,

Thanks for reporting. This problem is not known, and I cannot recreate it on KDE.

Please, file a new issue: https://youtrack.jetbrains.com/newIssue

Describe steps to reproduce (and please, provide a screencast if possible) and attach log files: https://intellij-support.jetbrains.com/hc/en-us/articles/207241085

0
Comment actions Permalink

Steps to reproduce the issue on Fedora with Gnome desktop:

Open PHPStorm or Android Studio or maybe other IntelliJ product and select to open a project. Then, as switch back to a word processor (or other program in which you type a text) and start writing something. You'll end up canceling the project opening realizing that the IDE stole your focus and got one of your spaces to cancel its project opening. You might even end up typing (what you were supposed to type in the word processor) into your source code before you know it.

 

0

Please sign in to leave a comment.