Build 977 and Apple's JDK 1.4

On my G5 they don't seem to play nice. I cleaned up my cache and created new project and made my target JDK to be 1.4.. and it croaks while loading the classes (allways at this class: sun/corba/se/internal/iiop/CDROutputStream_1_0.class).

Switched to JDK 1.3 and seems to work fine. Any OS X people having same issue? BTW, I never installed the quicktime java update so never had any issues with the JDK.

9 comments

Works fine for me here on dual G5.

g5:~ steven$ java -version
java version "1.4.1_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1_01-99)
Java HotSpot(TM) Client VM (build 1.4.1_01-27, mixed mode)

In fact I have to add, performance is excellent. Now if I could just stop those annoying logger error popups whenever I build my project...

(java.lang.Throwable at com.intellij.openapi.diagnostic.Logger.assertTrue(Logger.java:6) )

0

In article <21267932.1069734847810.JavaMail.itn@is.intellij.net>,
Aye Thu <thua@usa.redcross.org> wrote:

On my G5 they don't seem to play nice. I cleaned up my cache and created new
project and made my target JDK to be 1.4.. and it croaks while loading the
classes (allways at this class:
sun/corba/se/internal/iiop/CDROutputStream_1_0.class).

Switched to JDK 1.3 and seems to work fine. Any OS X people having same
issue? BTW, I never installed the quicktime java update so never had any
issues with the JDK.


I have had lots of problems, and since they started, 963 doesn't seem to
work so well either. There have been a few threads about Mac OS X issues
recently; check the archives if you want to see more.

JetBrains bought a new G5 recently, so hopefully they'll have it fixed
up soon.


--
Erik Hanson

0

A question for the G5 owners (not related to IntelliJ)...

Can you create a Java VM that uses more than 2 GB of RAM?

For example, can you set the mx parameter:

java -Xmx3000M com.company.SomeClass

On 32-bit wintel we are limited to around 1500M as the max. I was just wondering if the latest Mac OS and the G5 hardware broke that barrier.

Thanks,
Tim

0

doesn't look like it:

java -Xmx3000M
Error occurred during initialization of VM
Could not reserve enough space for object heap
Trace/BPT trap

This is on a dual G5 2gHz w/ 2gig of physical ram. Best I could do was -Xmx1956M. Maybe virtual memory doesn't help here. dunno.

eric

0

1956M is better than I can get on Windows or Linux.

It might be that the Java VM is still limited to a 2 GB heap limit. That's a shame because the OS/hardware combo is supposed to support more.

Thanks for trying.

0

In article <ehanson-lists-8ED022.15020026112003@host98.intellij.net>,
Erik Hanson <ehanson-lists@eh.cdeh.org> wrote:

I have had lots of problems, and since they started, 963 doesn't seem to
work so well either. There have been a few threads about Mac OS X issues
recently; check the archives if you want to see more.

JetBrains bought a new G5 recently, so hopefully they'll have it fixed
up soon.


The bug is now marked as "fixed". I can't wait for the next EAP
release...


--
Erik Hanson

0

The bug is now marked as "fixed". I can't wait for the next EAP
release...


We have some serious problems in version control support. We'll release new
build as soon as they get resolved.

--
Maxim Shafirov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


0

I'm not sure but I think that the VM wants the memory in one continuous block which 'creates' the limit if the operating system cannot provide that.

0

On 11/30/03 3:35 AM, in article
7517133.1070152541408.JavaMail.javamailuser@localhost, "Hezekiel"
<tilaus@almasoftware.com> wrote:

I'm not sure but I think that the VM wants the memory in one continuous block
which 'creates' the limit if the operating system cannot provide that.


As far as I know memory mapped files are implemented using general swapping
scheme and this is completely different memory VM uses.

--
Maxim Shafirov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


0

Please sign in to leave a comment.