Deploying web application to weblogic 9.2

Greetings,

After much searching, I haven't been able to find anyone with the issue I'm having, so I was wondering if anyone here could help. When I try to deploy a web-app to a remote server(which worked fine in weblogic 8.1), I receive:

<> <> <> <> ]]>
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.JMWrappedException: javax.management.MBeanException: MBean invoke failed: weblogic.management.ManagementException: The source file was not provided for activation of application: 'PubImage'.

It seems like the file isn't uploading, but I'm not sure why IDEA isn't doing such on deployment. It's a pretty new installation of weblogic with mostly basic settings (A node manager is running with some extra servers, they're all on the same machine.) I haven't been able to find any documentation on this other than a brief and unhelpful listing of the error code on bea's support site that says basically the same as the exception above.

Has anyone else had this issue when deploying remotely, or perhaps see something I'm probably doing wrong? Thanks for any help.

5 comments
Comment actions Permalink

We use WL 9.1. I can connect remotely. It runs extremely slow during debug. I cannot launch WL from within IntelliJ (linux at least).

0
Comment actions Permalink

Hello Colin,

Will be fixed in IDEA 6.0.5 and next Selena EAP build.

Greetings,

After much searching, I haven't been able to find anyone with the
issue I'm having, so I was wondering if anyone here could help. When
I try to deploy a web-app to a remote server(which worked fine in
weblogic 8.1), I receive:

<null> <servername> <> <> <Error occurred during deployment>

<servername> <> <> <Error occurred during deployment>

com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9
.mbeansModel.JMWrappedException: javax.management.MBeanException:
MBean invoke failed: weblogic.management.ManagementException:
The source file was not provided for activation of
application: 'PubImage'.

It seems like the file isn't uploading, but I'm not sure why IDEA
isn't doing such on deployment. It's a pretty new installation of
weblogic with mostly basic settings (A node manager is running with
some extra servers, they're all on the same machine.) I haven't been
able to find any documentation on this other than a brief and
unhelpful listing of the error code on bea's support site that says
basically the same as the exception above.

Has anyone else had this issue when deploying remotely, or perhaps see
something I'm probably doing wrong? Thanks for any help.



0
Comment actions Permalink

excellent, thank you.

0
Comment actions Permalink

Hello Nikolay,

I have IDEA 6.0.5 and am seeing the following error during deployment of a web application:

<> <> <> <> ]]>
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.JMWrappedException: javax.management.MBeanException: MBean invoke failed: weblogic.management.provider.EditSaveChangesFailedException: Can not save changes while prepare changes are still in progress
at com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.AbstractWL9MBean.invoke(AbstractWL9MBean.java:85)
at com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.runtime.DeployerRuntimeWL9MBean.activate(DeployerRuntimeWL9MBean.java:56)
at com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.Weblogic9LocalInstance.deploy(Weblogic9LocalInstance.java:35)

-


Thank you.

0
Avatar
Nikolay Chashnikov
Comment actions Permalink

Hello Galina,

Looks like you were working in WebLogic Console while IDEA is deploying a
module.

Hello Nikolay,

I have IDEA 6.0.5 and am seeing the following error during deployment
of a web application:

<May 24, 2007 11:39:00 AM EDT> <Warning> <Deployer> <BEA-149004>
<Failures were detected while initiating activate task for application
'AllegientWebApp'.>
<May 24, 2007 11:39:00 AM EDT> <Warning> <Deployer> <BEA-149004>
<Failures were detected while initiating activate task for application
'AllegientWebApp'.>
<May 24, 2007 11:39:00 AM EDT>
<null> <servername> <> <> <Error occurred during deployment>
<servername> <> <> <Error occurred during deployment>
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9
.mbeansModel.JMWrappedException: javax.management.MBeanException:
MBean invoke failed:
weblogic.management.provider.EditSaveChangesFailedException: Can not
save changes while prepare changes are still in progress
at
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9
.mbeansModel.AbstractWL9MBean.invoke(AbstractWL9MBean.java:85)
at
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9
.mbeansModel.runtime.DeployerRuntimeWL9MBean.activate(DeployerRuntimeW
L9MBean.java:56)
at
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9
.Weblogic9LocalInstance.deploy(Weblogic9LocalInstance.java:35)
----------------
Thank you.



0

Please sign in to leave a comment.