IntelliJ 5.1 and SVN 1.4

When using IntelliJ with a SVN 1.4 server i get an error everytime i
commit changes to the server.
The changes are in the repository after the commit but are shown still
changed in IntelliJ and i can commit them again and again.
The SVN release Notes says 'Older clients and servers interoperate
transparently with 1.4 servers and clients.'
So what is the problem ?

mfg
Carsten

14 comments

Hello Carsten,

You most probably tried some 1.4 aware SVN client, which converted your local
working copy to 1.4 format thus 5.1 is unable to parse that.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When using IntelliJ with a SVN 1.4 server i get an error everytime i
commit changes to the server.
The changes are in the repository after the commit but are shown still
changed in IntelliJ and i can commit them again and again.
The SVN release Notes says 'Older clients and servers interoperate
transparently with 1.4 servers and clients.'
So what is the problem ?
mfg
Carsten



0

Maxim Shafirov (JetBrains) schrieb:

Hello Carsten,

You most probably tried some 1.4 aware SVN client, which converted your
local working copy to 1.4 format thus 5.1 is unable to parse that.


I have never used any other svn client beside IntelliJ.
A friend of mine have exactly the same problem.

Carsten

0

Try to reset IDEA caches by deleting USER_HOME\.IntelliJIdea50\system directory.
Then perform a clean project checkout from SVN.

0

Serge Baranov schrieb:

Try to reset IDEA caches by deleting USER_HOME\.IntelliJIdea50\system directory.
Then perform a clean project checkout from SVN.


I have done so.
Still the same error. (Commit failed with errors)
I don't see anything special in the log.
Before switching to 1.4 server all was working.

Carsten

0

IDEA 5.1 was not tested with 1.4 SVN servers (as there was no SVN 1.4 at that moment) and therefore may have problems.

Please try IDEA 6.0.2 from EAP.

0

Serge Baranov schrieb:

IDEA 5.1 was not tested with 1.4 SVN servers (as there was no SVN 1.4 at that moment) and therefore may have problems.

Please try IDEA 6.0.2 from EAP.


6.0.2 seems to be working, but this is no solution, because 5.1 license
does not work with version 6.
Will there be a bugfix for version 5 ?

Carsten

0

Hello Carsten,

>> IDEA 5.1 was not tested with 1.4 SVN servers (as there was no SVN 1.4
>> at that moment) and therefore may have problems.
>>
>> Please try IDEA 6.0.2 from EAP.
>>
CS> 6.0.2 seems to be working, but this is no solution, because 5.1
CS> license does not work with version 6.
CS> Will there be a bugfix for version 5 ?

Currently we do not have any plans to release bugfix updates for version
5. We do not consider lack of support for SVN 1.4, released after IntelliJ
IDEA 5.1.2, to be a bug in IntelliJ IDEA 5.x.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Dmitry Jemerov schrieb:

Hello Carsten,

>>> IDEA 5.1 was not tested with 1.4 SVN servers (as there was no SVN 1.4
>>> at that moment) and therefore may have problems.
>>>
>>> Please try IDEA 6.0.2 from EAP.
>>>

CS> 6.0.2 seems to be working, but this is no solution, because 5.1
CS> license does not work with version 6.
CS> Will there be a bugfix for version 5 ?

Currently we do not have any plans to release bugfix updates for version
5. We do not consider lack of support for SVN 1.4, released after
IntelliJ IDEA 5.1.2, to be a bug in IntelliJ IDEA 5.x.


SVN Homepage says that it's compatible.
Imho there are 2 possibilities:
1. There is a bug in SVN
2. There is a bug in IntelliJ

Can you please check what the problem is ?
So if it's a bug in SVN i can contact the SVN-Team.

mfg
Carsten

0

They promise compatibility with their own clients which means that 1.4 client can work with 1.4 and previous metadata formats. 1.3 client will ask you to upgrade. IDEA 5.1 javasvn implementation cannot work with 1.4 metadata format.

So it's not a bug, it's a lack of new SVN version support in old IDEA versions.

0

I think Carsten is having problems using Idea 5.1 with a 1.4 server,
having not upgraded his working copy. This is supposed to work
(according to the SVN people), since the wire protocol didn't change
between 1.3 and 1.4.
R

0

We'll try to provide a fix for this within a couple of weeks. At the moment a workaround is to either use 1.3 SVN server with IDEA 5.1.2 or use IDEA 6.0.2.

0

Hello,

There is minor incompatibility between JavaSVN version used in IDEA 5.1 and Subversion 1.4.x servers. This incompatibility is not fatal, i.e. commit works but may report errors on commit completion. I will make a fix for 5.1 version in a few days.

Alexander Kitaev.

0

We've released an update for IDEA 5.1.2 SVN integration that fixes the described problem.

Please see http://support.jetbrains.com/kb/entry.jspa?categoryID=4&externalID=251 for update instructions.

0

Please sign in to leave a comment.