How to change saved password for remote git repository

Answered

I have changed password of my git repository and now I am unable to pull / push from / to it from PhpStorm. I have previously saved old password in PhpStorm. Now I just get error "fatal: Authentication failed for..." but I don't see a way how to enter new credentials.

How can I clear saved password cache for git?

Borut

14 comments
Comment actions Permalink

AFAIK Git doesn't use password, only key with passphase - maybe you need to regenerate this key? Or you have a Github account?

0
Comment actions Permalink

I don't use Github but I all the time work with private git (remote) repositories (for push / pull) where I have to enter username and password. This works fine in PhpStorm - I get modal window to enter credentials, but once remote password has changed I just got authetication error and pull / push failed. I was not provided an option to enter new credentials.

At the end I solved the problem to change master password in PhpStorm so all saved passwords were lost and again I was provided with modal window to enter new credentials. But downside of this approach is that also my other saved passwords for other projects were "lost" and I had to enter all of them again.

2
Comment actions Permalink

Yes, changing master password is a solution. You can also try to set PHPStorm do not remember passwords: http://www.jetbrains.com/idea/webhelp/passwords.html . But in both cases the drawback is that you loose all stored passwords.
We have another request that should cover this use case: http://youtrack.jetbrains.com/issue/IDEA-102861 .

0
Comment actions Permalink

using windows 7 and intellij 2017.1. Tried all of that, still telling me that it is not able to authenticate. Also deleted the KeePas file, no luck. Please help.

0
Comment actions Permalink

In my opinion PHPStorm has very poor workflow when you have changed your Github password. You have to forget all  passwords to get it working, which is a royal pain in the ass if you've saved many FTP passwords.

1
Comment actions Permalink

Issue is still there, even though related youtrack tickets are marked as fixed.

0
Comment actions Permalink

Pavel, since the issue posted here was fixed, it's been broken once again here: https://youtrack.jetbrains.com/issue/IDEA-134848
What version are you on?

1
Comment actions Permalink

You need to upgrade then, it's been fixed in 2017.3.

1
Comment actions Permalink

Still an issue with PyCharm 2017.3.3 on Ubuntu. The fix is to go into the Gnome Keyring and remove the entry in question.

1
Comment actions Permalink

Work around worked for me. I downloaded KeyPass and went to File > Settings > Appearance & Behavior > System Settings> Passwords, clicked on 'Do not save..", restarted IntelliJ and VCS asked for password again. 

0
Comment actions Permalink

Do not work all of these. PhpStorm 2018

0
Comment actions Permalink

The steps resolved issue for me in Windows

1. Go to Control Panel

2. Search for "Credentials"

3. Select Windows Credentials

4. Select github credentials from the list

5. Select edit and update your password then restart Intellij

0

Please sign in to leave a comment.