How to configure PHPStorm to debug on IIS

I installed PHP 5 on IIS on a Windows 7 64 bit machine using the Web Platform Installer. I am using PHPStorm as my PHP IDE but cant find any documentation on how to get debugging to work. PHPStorm launches my PHP web application but breakpoints do not get it.

Any help appreciated.

9 comments
Comment actions Permalink

Hello Ramesh,

What PhpStorm version do you use(1.0.x or EAP)? What debugger  - XDebug or Zend Debugger?

0
Comment actions Permalink

I am using EAP 2.0 and XDebugger

0
Comment actions Permalink

Ramesh,

How do you initiate debug session? From IDE or using "listen debug connections" button?

0
Comment actions Permalink

My background is Visual Studio and ASP.Net web development. I used the Debug button from the toolbar.

And thanks Nikolay for helping me.

0
Comment actions Permalink

Ramesh,

Please describe your scenario. What do you want to debug? The whole web application or just separate web page?

Also do you use any browser plugin for XDebug?

0
Comment actions Permalink

Nikolay,
I downloaded an open source PHP Web Application and set it up on my IIS7 on Windows 7 64 bit machine. I configured a separate website and am able to browse the web using http://localhost:90

So far so good.

Installed PHPStorm 2.0 EAP
Opened my local folder that contains the web app
Click Run and the app runs without any issues. Of course I had to configure the debugging information
Now I open a PHP file from the app and set a breakpoint at the first executable PHP line and click the debug button in the IDE
App runs but breakpoint does not hit.

I am looking for options in PHP Storm on how to tell it to use XDebug to debug my app hosted in IIS

thanks

0
Comment actions Permalink

Ramesh,

and set a breakpoint at the first executable PHP line and click the debug button in the IDE

XDebug(as well as Zend Debugger) has a special feature "break at the first line". Look at the attached file(break_at_the_first_line.png).
But we have a bug(in 100.36) related to this option so as workaround use "break at first line" in PHP->Debug settings. Look at the attached file(break_at_the_first_line_workaround.png).

Usually the problem with breakpoints related to problem with path mapping.
Please provide info about your server and settings which you made in PhpStorm.(I am interested in path mappings).

About browser plugins - you can find several links to such plugins here - http://xdebug.org/docs/remote



Attachment(s):
break_at_first_line_workaround.png
break_at_the_first_line.png
0
Comment actions Permalink

Have you enabled xdebug in php.ini? I guess you haven't.

0
Comment actions Permalink

Thanks to Dmitriy;s tip and Nik's help and major information from this blogpost

http://www.tellingmachine.com/post/Setting-up-XDebug-with-Eclipse-and-IIS-75.aspx

I have successfully configured PHPStorm 2.0 EAP to debug my PHP Web application hosted in IIS 7

Thanks everyone for helping out

0

Please sign in to leave a comment.