Extremely annoying autocomplete

Hey guys,

I was working in the editor today and noticed an EXTREMELY annoying autocomplete bug.

When attempting to write inline styles like this:
<div >

The editor autocomplete pops up when you have typed:
<div style

The first choice in the autocomplete box is a <style></style> element, and the second choice in the autocomplete box is the style attribute for the div tag.

Because the first choice in the box is a <style></style> element, when I type an equal sign:
<div style=

the editor autocompletes it to:
<div <style type="text/css"></style>

4 comments

Hi Andrew,

I have tried to recreate it on absolutely empty document (test.html) with no luck -- it works as expected (i.e. I see only single option in autocomplete popup, which is "style"). I have tried a few different simple scenarios (where I already have some tags present for header, body and footer) but it still worked fine for me (Windows 7 x32; latest EAP build PS-98.458).

Can you try and recreate the same behaviour in brand new project? Can you provide some example file where it can be reproduced (something like: "here is the file, if you type this in this position you will have this result")?

Anyway -- if you CAN reproduce it in separate file, you may post it to the issue tracker: http://youtrack.jetbrains.net/issues/WI#newissue=yes

0

You should also perform a Menu->File->Invalidate Caches.

0

As I remember I had similar problem in previous EAP too. It happens for me not each time and in files with php/html mix.

0

We can't reproduce this for further investigation. If you ever catch a standalone reproducible case - please file a bug.

0

Please sign in to leave a comment.