Can I force the IDE to use a specific path for $_SERVER['DOCUMENT_ROOT'] ?

Hi Community,

first of all - thanks for this great IDE - I'm just testing it and really think about switching to it from Zend. Still - I have some minor problems (a and b) - mostly due to path definitions that can't be resolved:


I've searched this forum and found - but there's no answer yet. I got the Same Problem:

I use this:


and as from there on nothing can be resolved anymore since every base information is located in this config.


in my CSS I use:


where / is my webroot. Although the IDE knows where that is it says it can't resolve this path :-?

Thanks in advance - Regards - Max


You should set resource root. Please see screenshot there:


thanks for the hint - unfortunately this didn't help. I had already set up the correct path (smb network drive mounted directly on a drive letter X). I added the "httpdocs" folder on X:/httpdocs as "Resource root". This still didn't help. In the Link you provided there was another addition from Alex who said one has to configure Setting -> PHP -> Include paths. Unfortunately I can't specify a PHP home since it's on a remote web server.(I need this "local-style" file editing using a smb network share so I can use the SVN subsystem and so on. (I tried the SFTP-Connection in the past but that's no solution in my case)


I have this problem too. I reported it in another thread.

Even doing a simple statement like: require_once '/config/db.php'; does not resolve (though it runs fine.. and netbeans has no issues with it). I tried adding the config folder to the PHP path and as a resource.

It's not a big deal, since it runs. But it's annoying see highlighted statements on the screen.


Actually, Max are you on  Mac? I am. If so, maybe it's an OS issue the IDE is having?


Nope - I'm having this on a standard WinXP box :-/ - unfortunately the hints from the other guys here didn't help :'-(


Hi folks,

I finally managed to fix it. The Hint from Dmitryi was correct - I only had to add the http-directory as resource root in File | Setting | Directories. It just wasn't "active" all the time. Only when entering new paths or modifying them in a CSS file it worked something changed. Finally an easy closing and reopening of the project seemed to have helped now - GREAT! :-)

Big thanks to you all! :)


Please sign in to leave a comment.