Smart keyboard internalization?

Answered

Obviously there is a feature in IDEA that should detect non-english keyboards and adjust the keymap accordingly.

I only learned about that at stackoverflow: http://stackoverflow.com/questions/35309220/smart-keyboard-internalization-for-idea

The help for the settings' keymap panel says that there should be a button "<language> layout support", but I don't have that button (latest IDEA version, German keyboard).

How comes that the feature is missing?

Is there any more information about the feature? What exactly does it do?

 

8 comments
Comment actions Permalink

This option enables support for certain hotkeys with "de", "fr", "it" and "uk" layouts. Without it some combinations will not work (like AltGr+7 to type "[" with German keyboard).

Related issue: https://youtrack.jetbrains.com/issue/IDEA-142462.

If you don't see this option, you are either using Mac, or IDE was not able to detect any of the supported input locales. Here is the relevant condition to enable this feature.

 

0
Comment actions Permalink

What setting would you recommend with Swiss keyboard layout (CH)? Disabling or enabling the "German layout support" option?

The layout is quite different from DE.

0
Comment actions Permalink

@Serge Banarov why should this option not be available on macOS? https://youtrack.jetbrains.com/issue/IDEA-165950 has so many duplicates and related issues but I don't see anywhere why macOS is excluded.

0
Comment actions Permalink

@Serge Baranov Any chance for an answer to my question?

Thanks and much appreciated.

0
Comment actions Permalink

I can only suggest to follow https://youtrack.jetbrains.com/issue/IDEA-165950 for updates. We'll try to provide several keymap presets for the national keyboards. Until then you will need to change the keymap according to your personal preferences.

@Marcel Stör no idea, I've asked the responsible developer to comment.

0
Comment actions Permalink

i accidentally enabled this feature once and my keyboard shortcuts stopped working. On Windows PC, everything works well without this option, even mentioned before AltGr+7 key combination. It seems to be only related to osx hipsters, maybe you could at least disable this annoying popup at every single startup for windows users? 

1
Comment actions Permalink

Hi. I have exactly the same situation as Serge : my keyboard is natively German but I use it with a Swiss Layout.

With any Windows 7 programs, no problem at all, they take the layout defined in Windows (Swiss). But with IntelliJ IDEA, my keyboard has a German layout !!!

How weird is it to override the windows layout !!

0
Comment actions Permalink

Once you have decided you don't need it, how can I get rid of the annoying popup?  It is exactly where error messages are normally displayed.

0

Please sign in to leave a comment.