IntelliJ IDEA 15.x causes X.org to crash with bus error under Debian testing

Answered

Within an hour of starting and using IntelliJ, it will cause X.org to crash with a bus error, taking me to a virtual console. I have to either reboot or log in and kill -9 the Xorg process, which will cause X to restart and show its GUI login screen.

Nothing in particular seems to trigger it, I am just editing Java files, moving the mouse and cursor around.

I've downgraded to 14.1.6 and I haven't experienced this problem yet with that version.

This is under Debian testing, running the following:

  • X.Org X Server 1.18.0
  • Linux 4.2.0-25-generic x86_64
  • Oracle JDK 1.8.0_74

Here is the tail output from /var/log/Xorg.0.log

[ 190.005] (EE)
[ 190.005] (EE) Backtrace:
[ 190.006] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4e) [0x5626c515649e]
[ 190.006] (EE) 1: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x1b9819) [0x5626c515a819]
[ 190.006] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f15a4bde000+0x33590) [0x7f15a4c11590]
[ 190.006] (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 (0x7f15a4bde000+0x785e8) [0x7f15a4c565e8]
[ 190.006] (EE) 4: /lib/x86_64-linux-gnu/libc.so.6 (__libc_calloc+0xd5) [0x7f15a4c59395]
[ 190.006] (EE) 5: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x70853) [0x5626c5011853]
[ 190.006] (EE) 6: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x6db35) [0x5626c500eb35]
[ 190.006] (EE) 7: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x5f8e5) [0x5626c50008e5]
[ 190.006] (EE) 8: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x60a2c) [0x5626c5001a2c]
[ 190.007] (EE) 9: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x145965) [0x5626c50e6965]
[ 190.007] (EE) 10: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x145ceb) [0x5626c50e6ceb]
[ 190.007] (EE) 11: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x16f7a2) [0x5626c51107a2]
[ 190.007] (EE) 12: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x1973c9) [0x5626c51383c9]
[ 190.007] (EE) 13: /usr/lib/xorg/Xorg (mieqProcessInputEvents+0x14f) [0x5626c51385cf]
[ 190.007] (EE) 14: /usr/lib/xorg/Xorg (ProcessInputEvents+0x19) [0x5626c5034c09]
[ 190.007] (EE) 15: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x5385f) [0x5626c4ff485f]
[ 190.007] (EE) 16: /usr/lib/xorg/Xorg (0x5626c4fa1000+0x57a53) [0x5626c4ff8a53]
[ 190.007] (EE) 17: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f15a4bfe870]
[ 190.007] (EE) 18: /usr/lib/xorg/Xorg (_start+0x29) [0x5626c4fe2de9]
[ 190.007] (EE)
[ 190.007] (EE) Bus error at address 0x0
[ 190.008] (EE)
Fatal server error:
[ 190.008] (EE) Caught signal 7 (Bus error). Server aborting
[ 190.008] (EE)
[ 190.008] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 190.008] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 190.008] (EE)
[ 190.008] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 190.132] (EE) Server terminated with error (1). Closing log file.

2 comments
Comment actions Permalink

You should report it to X.Org bug tracker.

0
Comment actions Permalink

I found this bug filed against the intel xorg server package in Debian. The bug report matches my problem exactly. It has to do with Java GUI apps not getting along with the intel SNA acceleration method.

Hard to tell if it's working for sure, since the problem is intermittent.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815013

 

1

Please sign in to leave a comment.