Connect to SQL Server localhost

I've seen a couple of posts on this topic, and all of them involve using jTds, which I know nothing about. All I want to do is connect to my local SQL Server instance. In the Data Sources and Drivers window, I chose the SQL Server (Microsoft) option and installed the drivers. When I create a new data source for SQL Server (Microsoft), it auto-fills "localhost" as the server name and port 1433. Not sure if I have to enter a DB name, but I tried it both with and without. I also chose to use Windows credentials instead of user credentials, which is the way I set it up. All of these options work fine for me in SQL Server 2014 Management Studio.

When I try to test my connection, I get a TCP/IP firewall error.

 

I connect to my local db just fine with SSMS and the settings I'm using are pretty much the default ones DataGrip fills in for me. I'm not experienced with firewall settings, but DataGrip appears in my Windows Firewall screen with full allowance on all ports, so that seems all correct. I even tried entering my external IP address as the server name. Where am I going wrong?

3 comments
Comment actions Permalink

The issue could be that database is configured to use Named Instance, rather than tcp port for connection, and these settings work with SQL Server Management Studio. If so, please delete port number from the connection settings and specify named database instance (in Instance field) to connect to.

Also please check this using jTDS driver.

0
Comment actions Permalink

Since not working

0
Comment actions Permalink

If it is an "express" vesion of Sql Server, you may have to specify the instance name.

Anyway, check the connection with Sql Server Management Studio

 

0

Please sign in to leave a comment.