could not close the output stream for file

I'm using PhpStorm to develop my online website and using FTP Synchronization for that. everything was good but unfortunately now when i saving my file, php file not uploading and just print this error in file transfer window:

[3/4/2016 2:16 AM] Failed to transfer file 'C:\Users\hamid\PhpstormProjects\dlepersian.ir\engine\inc\hyvip.php': could not close the output stream for file "ftp://dlepersian.ir/engine/inc/hyvip.php".
11 comments
Comment actions Permalink

Hello,

Please try to enable File | Settings | Build, Execution, Deployment | Deployment > Your server > Advanced options > Passive Mode and check if the issue can be reproduced after that.

1
Comment actions Permalink

Hello, thanks for your answer, but problem happens when that option enabled.

this is my default options:

Passive Mode: Enabled

Compatibility Mode: Enabled

Always use List Command: Enabled

Encoding: utf-8

1
Comment actions Permalink

Thanks!

We would like to take a look at the detailed log. Please enable debug information collection by following next steps:

  1. Go to Help > Configure Debug Log Settings.
  2. Add there com.jetbrains.plugins.webDeployment line.
  3. Restart PhpStorm.
  4. Reproduce the issue.
  5. Send the IDE log file to us. You can locate it with the help of the following article: https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files.
0
Comment actions Permalink

http://dlepersian.ir/phpstorm_log.zip 

I was thinking the problem maybe caused by my Server, so I changed That, But after 2-3 hours, problem happens again. this is what you want. thank you for your helps.

1
Comment actions Permalink

I have the same problem, it used to work in the passed, this doesn't happen every time

1
Comment actions Permalink

I am having this problem as well... This does not happen in FileZilla or Netbeans connecting to the same server. If I toggle between passive modes or go to the server and force a disconnect it will re-connect and work but only for a couple of uploads before throwing the error again.

This is the only deployment capable software I actually PAY for so having this as an error is frustrating when it does not work.

1
Comment actions Permalink

Unfortunately, currently there's no solution. For the reference: https://youtrack.jetbrains.com/issue/WI-20698

0
Comment actions Permalink

Hi Eugene,

any update on this issue? When will it be resolved?

Thanks,

Michael 

0
Comment actions Permalink

Unfortunately, there is no ETA available on this issue resolution, sorry.

-1
Comment actions Permalink

Same problem here when trying to upload files to a project that was previously deployed with PHPStorm / FTP without issues.

 

EDIT: I selected every folder in the project and deployed it manually via context menu. It worked. So PHPStorm is overwhelmed by a few dozen files apparently.

0
Comment actions Permalink

Hi Michael, please check out the solution mentioned here: https://youtrack.jetbrains.com/issue/WI-47822 

Works like a charm for me.

0

Please sign in to leave a comment.