Mouse interactions not working, also updates not working

Answered

I have IntelliJ IDEA Ultimate Version 2016.1.3 when I opened it today, it won't respond to the mouse/cursor. The menu bar at the top works, as do the x, -, and + window buttons, but nothing actually inside the windows will respond to mouse clicks. The app does respond to the keyboard. So, for example, I can navigate using Tab, Enter, Esc, etc.

I found this StackOverflow post which seems related to my problem:
http://stackoverflow.com/questions/19769017/intellij-idea-not-responding-to-mouse-clicks

In one of the comments, a person mentions that the problem seems to be with using multiple monitors. When I opened IntelliJ, it did open up three previous projects that I had opened before, and they opened two were on one monitor and one was on the other. Unlike the commenter though, my problem was not solved by closing some, or even all of the projects and restarting in IntelliJ. It seems to be stuck in this state.

Also, the update is not working. If I select 'Check for Updates...' and then select the 'Download' button with the keyboard, I can see the download bar appear briefly, and then the initial window with the 'Remind Me Later', 'Download', etc. buttons appears again. So I can't update IntelliJ either.

I am running on a MacBook with OS X El Capitan, 10.11.6.

7 comments

It worked after disconnecting my monitors, then opening IntelliJ, closing it, and then reconnecting my monitors, and opening IntelliJ again.

This will be very irritating if this keeps happening.

Also, I was able to install the update simply by installing the whole application from the .dmg from jetbrains.com, like you suggested.

0

I am experiencing the same issue with IntelliJ Ultimate Edition version 2016.2.2 on Fedora 24. I tried re-installing IntelliJ, but the problem recurs.

Why is this question marked as "Answered" when the root cause has clearly not been determined and neither a solution nor workaround has been put forward?

4

Has a bug report been raised for this? I tried searching on Youtrack but couldn't really tell.

Edit:

Could be this: https://youtrack.jetbrains.com/issue/IDEA-162804. It seems you get different search results on Youtrack when you're signed in.

Given that this post is the top result for "intellij mouse not working linux" on Google, it might have been worth someone from Jetbrains adding a comment on this ticket.

1

Can someone froom IntelliJ please response to this and not just say "Please raise a bug" this issue is very irritating and this is the ONLY article I've found relating to the issue

0

Your issue may be completely different, please file a bug and describe in detail what you observe and provide the logs, OS/Java version, window manager, etc. Without this information it's impossible to help, sorry.

0

Post is closed for comments.