Windows 10 bash (Insider Preview) doesn't work on PHPStorm terminal.

Don't if this a Windows issue or PHPStorm issue but it be great if if Windows bash can work inside PHPStorm terminal.

25 comments
Comment actions Permalink

If I try to point to the new bash.exe via the Settings > Terminal > Shell path > Shell Executable Path, I can't see it in the picker (it's there in the file system). If I manually add the path, I get the error: Specified cannot be found. If I cancel the picker and manually change the path in the Shell path field, it allws me to Apply and OK, but when I open the Terminal I get the error: java.io.IOException: Couldn't create PTY.

This is the new Windws 10 Insider Preview 14316_rs1 (160402-2217) release. 

 




0
Comment actions Permalink

+1 

 

Please fix this!

0
Comment actions Permalink

I got it to work.  Just copy bash.exe to "C:\bash.exe" and put "C:\bash.exe" in "Settings > Terminal > Shell path" then it will work. 

6
Comment actions Permalink

Thanks. Good for a work around, but not for a fix, surely.

0
Comment actions Permalink

UP....

I've just downloaded and installed  Windows 10 1607 + bash  and try to use bash as terminal  inside PHPStorm 2016.2 and got the same error...

Any news on that ?

0
Comment actions Permalink

This is not a duplicate of the issues related to users trying to include a path with spaces. This is an issue with the selection menu not displaying bash.exe as a choice in C:\windows\system32, additionally the Jetbrains menu for settings does not allow you to enter a path and click "OK", it forces you to select from the list of files.

0
Comment actions Permalink

Worked finde for me by setting it to C:\Windows\System32\bash.exe, only problem is that it open in / and not my project dir, not sure if bash has option for that. I know you dan do 
```
C:\Windows\System32\bash.exe -c "vi somefile.txt"
```
and it will run that in a gui but that didnt seem to work for cd project path

1
Comment actions Permalink

@Ruben

This is really strange ! Same settings do not work on my W10...=> java.io.IOException ...

0
Comment actions Permalink

One thing is that I work on SSD's so everything is pretty fast, yet listing System32 folder took about 3-4 min, and i had to scroll forever to find bash.exe.

 

 

0
Comment actions Permalink

@Christian I get the same error and I can't find the bash.exe in the tree view. Setting it manually gives the same error. I dont't know how @Ruben could open that. 

 

@Ruben There are some settings are we missing?

0
Comment actions Permalink

I have no Idea :

https://youtu.be/SazjEAS1vuw

 

I made it into a video

0
Comment actions Permalink

@Artem. You are right. It works now

0
Comment actions Permalink

Confirmed here too !!! Artem you made my day ! 

Maybe this can be added to the official FAQs !! 

0
Comment actions Permalink

@christian :
I don't believe it's a solid solution though, i think it is a bug with windows symlinks..

@artem
yeh, i noticed the same, i wanted to add an argument to have it load/start in the right directory (although it would be a setting per project) which just broke the whole terminal when I did

it would be nice if there was some kind of config when selecting bash/WSL as your terminal , like to be able to set a path translation, eg C:\ would translate to /mnt/c/

0
Comment actions Permalink

@artem : Yes I confirm that it is not an solid solution...;)  Today, I've got the error again .. And fix it by changing terminal settings to this : C:\Windows\WinSxS\amd64_microsoft-windows-lxss-bash_31bf3856ad364e35_10.0.14393.351_none_79648c7a5a883c6f\bash.exe

 

Yesterday evening I did an apt-get update in bash.exe... Maybe this has something to do with... Is it the Same for you ?

0
Comment actions Permalink

I had this problem with Idea, and it took me a while to figure out that my shortcut was actually launching the 32bit version of the IDE. Once I opened the 64bit version, I could just change cmd.exe to bash.exe and it works.

1
Comment actions Permalink

After installing the 64-bit jdk from Oracle and running the PhpStorm64.exe, bash.exe is running fine. Thanks @Mark!

0
Comment actions Permalink

@Rodrigo, glad to hear it's working! I had been researching this all afternoon, and then later in the day realized I couldn't even launch bash from the cmd.exe terminal. I came across a discussion talking about how the the 32bit cmd.exe couldn't launch (the 64 bit) bash.exe. When I read that, it sort of clicked, and I realized I had been using the 32 bit version of Idea.

0
Comment actions Permalink

Working with fish on Webstorm terminal on Windows 10 using 64bit jdk, awesome

"C:\windows\system32\bash.exe" -c fish -cur_console:p

0
Comment actions Permalink

Also with ZSH

`"C:\windows\system32\bash.exe" -c zsh`

Or simply use `bash.exe` 

1
Comment actions Permalink

for version phpstorm 2017 (windows 10) settings work!!!

change

Path to the project

change 

win username
0
Comment actions Permalink

I am using windows 7 + intellij ultimate 2017.3

I can launch my git-bash after setting the "shell path", however, a problem I face is, it always pops up a new bash window instead of a embedded frame within the "terminal" view.

Does any one know how to fix this please ?

 

<Issue>

 

<settings>


0

Please sign in to leave a comment.