Fonts are Blurry on the Ultimate Edition - Mac

Answered

Hi,

I have just downloaded the Intellij Ultimate Edition and I am loving it. However, the text is blurry compared to the community edition (the one I used to use). It seems like the fix for windows users is disabling the DPI scaling (https://intellij-support.jetbrains.com/hc/en-us/community/posts/206809965-new-user-hi-dpi-Fonts-are-all-blurry?input_string=Fonts%20are%20Blurry%20on%20the%20Ultimate%20Edition%20-%20Mac).

However, I don't know how to do this on my mac? I use a Macbook Air 13 inch. 

8 comments

See https://youtrack.jetbrains.com/issue/IDEA-147241.

What antialiasing setting do you use? Did you try grayscale?

0

I'm using Subpixel for both IDE and editor. Grayscale doesn't fix it, it still looks blurry regardless. I've looked at that forum before, but the solutions provided doesn't work for me.

0

Font rendering is the same for CE and Ultimate of the same version. Note that 2016.1 is using Java 8, while the older versions run on 1.6 by default on Mac, hence the font rendering difference.

Do you run on the bundled Java 8 or on Oracle Java 8? Do both of them have the same problem? See https://intellij-support.jetbrains.com/hc/articles/206544879.

0

Hi,

I've tried the Oracle Java 8 and it's much clearer now. However, the font is now really thin. How can I make it thicker?

Thanks,

 

0

I'm having the same issue, but only when using the version 15 of any IDEA's products. Using the version 14 the font is crystal clear. I'm using Windows 8 in a external monitor 1920x1080, which I selected as my main monitor (my laptop monitor is 2160 x 1440).

You can see the difference between Intellij 14 and PyCharm 15 here: http://i.imgur.com/qTXOls2.png

0

This issue is Mac specific, so yours is different. Try setting antialiasing to Grayscale mode. Submit a ticket to support to get help.

0

Please sign in to leave a comment.