Pinch-to-zoom not working

Answered

Hello,

For some reason, my pinch-to-zoom is not working, neither is the mouse wheel zoom. The setting for 'Change font size (Zoom) with Command+Mouse Wheel' option is checked. Tried disabling, restarting, enabling, restarting but to no avail. My system wide zoom gesture is turned on and works fine in other applications (for example, it works perfectly fine in IntelliJ). Tried restarting my computer, as well as doing the 'Invalidate Caches/Restart' option from the file menu.

I'm using a MBPR with Mac OS 10.11.4.

PyCharm 2016.1.2
Build #PY-145.844, built on April 8, 2016
JRE: 1.8.0_40-release-b132 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

I appreciate any help or suggestions.

Thank you.

12 comments
Comment actions Permalink
Official comment

Hello,

Thanks for your reports.

 

We received few similar reports about the problem, I've added them as comments to the issue: https://youtrack.jetbrains.com/issue/IDEA-145815, please follow it for updates. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

> Also resolved another issue I had with Pycahrm 2016.1.2, which was horizontal scrolling being disabled in the Python Console.
Horizontal scrolling in the Python console will be enabled in one of the next PyCharm releases.

Comment actions Permalink

I have a setup similar to yours (MBPR, El Capitan 10.11.4, Pycharm 2016.1.2) and pinch-to-zoom is not working for me as well.

1
Comment actions Permalink

I went back to Pycharm 5.0.3. Pinch-to-zoom works there. Also resolved another issue I had with Pycahrm 2016.1.2, which was horizontal scrolling being disabled in the Python Console.

1
Comment actions Permalink

Thank you for the input, glad to hear that it's not just me having this problem. It seems like PyCharm 2016.1.2 is having some issues. I didn't notice the Python Console issue as I don't use the Python Console from inside PyCharm. Hoping it gets resolved soon.

0
Comment actions Permalink

@Anna Morozova

Thank you for taking note of the issue. I will be following the YouTrack post.

0
Comment actions Permalink

Make sure that the setting Change font size (Zoom) with Ctrl+MouseWheel is enabled.

Ref: https://www.jetbrains.com/help/webstorm/2017.1/zooming-in-the-editor.html

0
Comment actions Permalink

I'm having still the same problem more than a year after this thread.

The official YouTrack ticket in the official response leads to a 404. 

I updated my Java SDK as described here: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879

I also enabled 'Change font size (Zoom) with Ctrl+MouseWheel' in Editor > General.

These are my specs:

PyCharm 2017.2
Build #PY-172.3317.103, built on July 25, 2017
Licensed to Peter Ullrich
Subscription is active until ---REDACTED---
For educational use only.
JRE: 1.8.0_152-release-970-b1 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

0
Comment actions Permalink

Pinch and zoom broke for me on pycharm with the most recent update.  I have tried turn on the Ctrl+MouseWheel setting and restarting pycharm without success.

PyCharm 2017.2.2
Build #PY-172.3757.67, built on August 21, 2017
JRE: 1.8.0_152-release-915-b10 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

0
Comment actions Permalink

Hi Jawineinger! This is a known issue: IDEA-175106, please check this workaround: https://youtrack.jetbrains.com/issue/IDEA-175106#comment=27-2380983

0
Comment actions Permalink

PyCharm 2017.2.3
Build #PY-172.3968.37, built on September 1, 2017
Licensed to Sivabudh Umpudh
Subscription is active until September 25, 2017
JRE: 1.8.0_152-release-915-b11 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.5

Still has this problem. And I had read the workaround effect. It is quite scary for me.

0
Comment actions Permalink

Hi Sarit R! 2017.3 EAP with the fix is already live, you can ignore workaround and try this build.

0
Comment actions Permalink

Hi Pavel. Thank you for your quick response. I will give it a try.

0

Please sign in to leave a comment.