Error starting Intellij Idea

Answered

Hi,

 

I just have downloaded trial version of Intellij Idea Ulitmate

  • Version: 2016.1.1
  • Build: 145.597
  • Released: March 31, 2016

on Arch Linux, Openbox.

 

I have unzipped tar file and tried to start Intellij Idea. But I am getting following error.

 

Command 'sudo /home/david/.IntelliJIdea2016.1/system/tmp/create_desktop_entry_.sh' returned 127
Output: Error creating textual authentication agent: Error opening current controlling terminal for the process (`/dev/tty'): No such device or address

 

Thanks

5 comments

Does it occur before you can see any other UI? Does IDE exit or hang?

If it hangs, please provide jstack dump: https://intellij-support.jetbrains.com/hc/articles/206544899 .

As for the error, there is a related report for a different product. See if the workaround suggested in comment #3 works for you.

0

Thanks for reply.

 

It doesn't hang.

 

I am at UI Themes -> Create Desktop Entry

 

Create Desktop Entry for integration with system application  menu.

1) I select "For all users"

2) click on create launcher script on lower right hand corner

3) Please specify path where script should be created.

default path is /usr/local/bin/idea

(I created idea folder manually using sudo and changed owner of idea folder to myself, still gets same error)

4) click Next default plugins on lower right hand corner

5) click on Next featured plugins

6) Install Live Edit tools

7) click on Next start using Intellij Idea on lower right hand corner.

Error dialogue is displayed.

 

If I select "For all users" check box in step 1 ) then I get above error.

If I don't select check "For all users" in step 1)  then I get "Launcher script creation failed with 127"

 

Please note that it doesn't hang. I did this 3 or 4 times.

0

I have just killed the process from command line and restared Intellij Idea. Now it doesn't show me create launcher script dialogue box. I start by executing bin/idea.sh script. I get screen

Create new project

Import Project

Open

Checkout from version control

dailogue box.

 

Please let me  know if everything is correct because I am trying Intellij Idea for first time since I am an Eclipse user.

 

0

Creating desktop entry is optional, it just adds a shorcut to the desktop. If it doesn't work for you, it's not a big problem, you can either start it with idea.sh or create a desktop shortcut for idea.sh manually.

See https://www.jetbrains.com/help/idea/2016.1/installing-and-launching.html#desktop_shortcut if you fix the issue with authentication agent on your system and would like to try it again.

0

Hi,

Thanks for reply. I don't need desktop entry. I use openbox and dmenu launcher. So just setting path to $IntellijIdeaHome/bin folder will work for me.

 

Thanks again.

0

Please sign in to leave a comment.