Indexing is frequently failing

Answered

Recently, the regular indexing of Java files as I edit them has stopped working.

I'm using IntelliJ IDEA Ultimate 14.1.7

Symptoms are:

- stops underlying unknown symbols and offering fixes (like create method, etc)

- stops catching general syntax/compilation errors

- syntax coloring stops highlighting return types and method names, etc.

I can't work in the way I'm used to working in short.

Workaround: Restarting IntelliJ idea fixes it for a few minutes to and hour, then its back.

I have tried, with no special success (ie some of these work for a while then the problem returns)

- File->Invalidate Caches and restart

- manually cleaning out <home>\.IntelliJIdea14\system (I originally cleand out all of IntelliJ IDEA but then brought restored a backup of my "config" directory because I lost too many settings)

- upgrading from 14.1.6 to 14.1.7

- creating an entirely new project (for my existing source and settings) 

- rebooting my machine (windows 7 64bit)

None of these works for more than an hour and I'm back to restarting IntelliJ IDEA every 10 - 30 mins

I can't pinpoint when it started, but it might be when I recently moved to working on a branch. (I svn switched at the command line, not in the project).

Since I created the project from scratch, installed a new version of IntelliJ and rebooted, the only thing that remains constant is

1. the source code I'm using (same code on the disk)

2. the IntelliJ config with all of my settings

 

8 comments
Comment actions Permalink

Does the issue persist with 2016.1.3 from http://www.jetbrains.com/idea/download/index.html ? If so, please submit a ticket to support with the logs folder attached (https://intellij-support.jetbrains.com/hc/articles/207241085).

0
Comment actions Permalink

Thanks for the quick response Serge. I have 14.1.7, which I believe is the latest Ultimate that my license entitles me too. If I upgrade to 2016.1.3 Ultimate, I'll have to pay right?

0
Comment actions Permalink

Yes, it's 2 major versions ahead of 14, so it would be a paid upgrade.

0
Comment actions Permalink

Hmm, then that'll take a bit of red-tape with my company. In the meantime, if this is not a known issue in 14, known to be fixed in a later release, then it probably won't help.

I've started looking at the idea.log to see if there are any clues and I've noticed a few odd SVN entries there. Though this is the first time I've ever looked at that log, so perhaps its normal?

2016-06-07 10:21:59,019 [ 19042] INFO - tor.impl.FileEditorManagerImpl - Project opening took 12491 ms
2016-06-07 10:22:08,414 [ 28437] WARN - svn.auth.AuthenticationService - Could not get authentication. Type - svn.simple, Url - https://<my svn server>
2016-06-07 10:22:17,226 [ 37249] INFO - svn.commandLine.CommandRuntime - Detected warning - svn: warning: W155007: 'C:\trunk\idea_trunk_fixed_maven\.idea' is not a working copy

2016-06-07 10:22:34,686 [ 54709] INFO - svn.commandLine.CommandRuntime - Detected warning - svn: warning: W155007: 'C:\trunk\idea_trunk_fixed_maven' is not a working copy

2016-06-07 10:22:34,856 [ 54879] INFO - ins.idea.svn.SvnChangeProvider - Rename not found for C:\trunk\src\<a file of mine> 

 

0
Comment actions Permalink

One other reason to suspect it's svn related, is that the one unusual thing I did recently with this source code is to switch to a branch, and later merge from the trunk into that branch (a feature branch in other words) - I did all of this with svn on the command line, though I use IDEA SVN integration for checkins in general and have used it since.

Is there something in the SVN integration that could cause regular indexing to fail in java classes?

0
Comment actions Permalink

It's unlikely to be SVN related, but you can disable Subversion plug-in, restart IDEA and see if it helps.

0
Comment actions Permalink

Okay, I disabled SVN and every other plugin and the problem persisted.

I cleaned out everything, reinstalled, rebooted, started a new project from source, and the problem persists.

What happens is I program normally for anywhere from 5 to 30 mins and I notice that it stops flagging syntax errors or missing symbols (e.g. i often type a method call then use Alt-Enter and select Create Method - but it's not even flagging the method call as a problem!).

So I decided to install version 15.0.6. My license doesn't extend to that, but I got the 30 day trial. It's a bit crashy i have to say, but otherwise the problem was _completely resolved_. No problem, even with the same project and the same settings (I left settings in place when uninstalling/upgrading, then worked on the same project as 14.1.7)

So it's definitely a problem with 14.1.7, and since I first saw it with 14.1.6b and never before that, it seems like a new bug in that version that was fixed in a newer one. Prior to that I had 14.1.1 which never showed the problem.

Does my license not entitle me to a patch on 14.1.7 to fix this? Failing that it's going to take a while to justify and upgrade to the new licensing scheme, so I'm tempted to give up on Ultimate and move to the latest community edition

0
Comment actions Permalink

The issue seems to be specific to your project somehow. Probably triggered by some file. Can't tell more without the logs or without being able to reproduce it. We do not plan to release more updates for 14.1.x branch, except critical security fixes.

0

Please sign in to leave a comment.