Keystrokes going to IntelliJ instead of terminal in IntelliJ

Answered

I often startup vi in a terminal in IntelliJ. When I press shortcut keys like 'Ctrl + N' etc. IntelliJ picks it up as shortcut keys and open up a dialog etc. Anyway to get around this?

0
2 comments

Do you have Override IDE Shortcuts option enabled in the Terminal settings? See also https://youtrack.jetbrains.com/issue/IDEA-153536.

0

Same problem for me, seems like 'Override IDE Shortcuts' does not work for all shortcuts. Have not found any solution yet to make 'CTRL-n' not opening up the class-search dialog. I´m using cygwin bash as default terminal, 'Override IDE shortcuts' enabled, but some shortcuts still are passed to IDE and the terminal. Makes no difference whether terminal is in a separate window, floating or embedded.

Very annoying when working with screen in an ssh session...

 

And I am using Windows, so the linked apple issue does not help me.

0

Please sign in to leave a comment.