Cannot connect to remote PostgreSQL database; Datagrip defaults to local IP

Hi,

I have been trying to connect to a remote PostgreSQL database through Datagrip. However, each time it fails saying it cannot connect to the host. 

I have set the host to be the host of my remote database, but the host IP that shows up in the error messages is my own local IP. No matter what configurations I change, I cannot seem to get the "host" value to change.

Is this a known bug, or are there potential workarounds? I effectively cannot use this product until this is fixed.

 

This configuration works perfectly in PgAdmin III, by the way.

Thanks.

3 comments
Comment actions Permalink

I have the same issue - I am trying to connect to my local postgres instance on my local machine on a Mac.  If I click "Test Connection" the testing window will say "connecting to database" for around a minute, then display:

Connection refused to host: localhost; nested exception is:
java.net.ConnectException: Operation timed out

What makes this hard to troubleshoot is that the test connection modal even when hitting cancel does not go away, so you have to wait a minute before you can modify the settings and try again.

I can use psql on the command line w/the same options and the connection works fine.

1
Comment actions Permalink

Hi,

Could you provide screen shots of your datasource settings?

Thank you.

0
Comment actions Permalink

I'm getting a connection refused after updating my Intellij to latest: 2017.2.5 built on Sept 26th, 2017.  It was connecting fine before.  Trying to connect to a Postgres DB on AWS.  If I boot the app from intellij the app can connect fine.  I just can't connect through IntelliJ's Database panel.

1

Please sign in to leave a comment.