2016.2 very slow

Hi,

I've upgraded to 2016.2 today (Build #PS-162.1121.38, built on July 12, 2016) and immediately noticed considerable slow down when doing anything in the IDE (editing any file, running any Grunt/Gulp jobs, etc.). Basically, the same thing described here https://youtrack.jetbrains.com/issue/IDEA-157837. Actually, IDE just stopped responding after running one of the Grunt jobs now (which I'm running every day multiple times and never had issue up til now).

Unlike that ticket mentioned above, I'm on Ubuntu (16.04) and have a decent workstation laptop (quad core i7, 16GB RAM, SSD). I'm interested if anyone else is experiencing the same issue?

Thanks.

39 comments

Hi, same issue here. But just "Invalidate cache / Restart" fix the problem. Hope help someone.

0

Excluding as many folders as possible worked for me. Indexing large files created by Grunt/Gulp every time after a build was probably the cause of this problem but I excluded other folders too.

1

For those wondering here is how to change vm options!

-Xms1024m
-Xmx5000m
-XX:MaxPermSize=350m
-XX:ReservedCodeCacheSize=96m
-XX:+UseCompressedOops

Managing *.vmoptions file

The location of the *.vmoptions file depends on the operating system you are currently using:

Mind the abbreviation scheme of the PhpStorm name: XX corresponds to the PhpStorm version.

  • For Windows systems: <PhpStorm installation folder>/bin/phpstorm.exe.vmoptions or <PhpStorm installation folder>/bin/phpstorm64.exe.vmoptions
  • For *NIX systems: <PhpStorm installation folder>/bin/phpstorm.vmoptions or <PhpStorm installation folder>/bin/phpstorm64.vmoptions
  • For macOS systems, you have to make a copy of the phpstorm.vmoptions file in the IDE preferences folder and then edit this copy. The reason is that app bundle is signed and you should not modify any files inside the bundle.
    • Since version 2016.1, the file /Applications/PhpStorm.app/Contents/bin/phpstorm.vmoptions should be copied to ~/Library/Preferences/PhpStorm/phpstorm.vmoptions.
    • For earlier versions, the file /Applications/PhpStorm<version>.app/Contents/bin/idea.vmoptions should be copied to~/Library/Preferences/PhpStorm<version>/idea.vmoptions.

To avoid editing files in the PhpStorm installation folder, one should:

  1. Do one of the following:
    • Use the main menu command Help | Edit Custom VM Options to create a copy of the phpstorm.vmoptions file in the user home. Refer to Edit Custom VM Options for details.
    • Copy the existing file from the PhpStorm installation folder somewhere and save the path to this location in the environment variable WEBIDE_VM_OPTIONS.
    • Copy the existing file <PhpStorm installation folder>/bin/phpstorm.exe.vmoptions or <PhpStorm installation folder>/bin/phpstorm64.exe.vmoptions from the PhpStorm installation folder into the location under your user home.
  2. Edit this file in the new location.

If WEBIDE_VM_OPTIONS environment variable is defined, or the *.vmoptions file exists, then this file is used instead of the one located in the PhpStorm installation folder.

0

I'm on Ubuntu 16.04 with Core i5 and 16 Gb RAM, using 2017.1.1. I have a relatively large project, and after recent additions CLion seems to be scanning indices forever, and after some time, it becomes so slow I need to close clion, sometimes even kill it. This is unacceptable for a "professional" tool that we pay for!

 

0

Additional remark, the correct tip in my case was from camden_kid

I accidentally had a log file inside the tree which was a few Mb, and aparently CLion scans every file. Moving the log file out of the way helped.

0

I had this annoying issue on Windows  with IDEA 2016.3.5 : when typing a key, took several seconds to appear on screen, meanwhile the GUI froze

I had a dark theme setup ( Darcula ) + the Afterglow plugin installed.

I just uninstalled Afterglow and switched back to "Intellij" theme, and no more lag !! (for the moment at least, I hope it remains that way)

So not sure if this is the solution, but for the moment it works for me

 

0

I install JDK from JB - not help :(

I upgrade PhpStorm from 2016 to 2017 - not help :(

Then in my mac i edit file (and make backup before): /Applications/PhpStorm.app/Contents/bin/phpstorm.vmoptions and change below content:

  

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseCompressedOops

 

To this (from one comment to this article):

-server
-Xss256k
-Xms1536m
-Xmx1536m
-Xmn512m
-XX:PermSize=350m
-XX:MaxPermSize=350m
-XX:MetaspaceSize=350m
-XX:MaxMetaspaceSize=350m
-XX:+UseParNewGC
-XX:SurvivorRatio=8
-XX:+UseConcMarkSweepGC
-XX:+CMSScavengeBeforeRemark
-XX:+CMSPermGenSweepingEnabled
-XX:+UseCMSInitiatingOccupancyOnly
-XX:+UseCMSCompactAtFullCollection
-XX:CMSFullGCsBeforeCompaction=0
-XX:CMSInitiatingOccupancyFraction=70
-XX:ReservedCodeCacheSize=240m
-XX:+HeapDumpOnOutOfMemoryError

And now everything works smoothly :)

0

Funny how till 2018 the problem still persists, been running fine for 2 months then suddenly the inspector stops functioning completely. If I wasn't required to use this for my school projects, I would ditch this utter garbage almost instantly.

0

@N1293jfask3vaj What are the exact problems with inspector? Could you provide more details please?

0

Please sign in to leave a comment.