Typing lag in 2016.2

Answered

Hi,

I'm developing Android on IntelliJ IDEA.

I upgraded it to 2016.2 recently.

But I found that the typing becomes so laggy in this version.

Is there any way to fix it?

The followings are my vmoptions,
-Xms512m
-Xmx8192m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=240m
-XX:+UseCompressedOops

I added these lines into gradle.properties after the upgrading was completed.

# must bigger than javaMaxHeapSize "4g" which was set in build.gradle of the module.
org.gradle.jvmargs=-Xmx5120m

These are the screen recordings about the typing issue.

Laggy IntelliJ IDEA - https://youtu.be/_NPs1KC3YCw
Smooth Sublime - https://youtu.be/5at1sq_DQ5k

Thanks.

5 comments
Comment actions Permalink
Hi,

Here are CPU snapshot and logs files,
https://www.odrive.com/s/9ed354d8-c242-4dbe-b636-3a12f18d09d4-57936227
And the scrolling becomes laggy too.

Thanks.

0
Comment actions Permalink

Do you use external display?

Does it help if you disable Android Parcelable code generator (0.7.0), Builder Generator (1.1.1) plug-ins?

0
Comment actions Permalink

Hi,

Yes, I use external display.

And it becomes laggy after I run debug on emulator.

Disable the plug-ins doesn't help.

Is it related to the assembleDebug error messages?

https://www.odrive.com/s/c657280c-4911-47f9-964b-2b22991b27ec-57955ce4

After I upgrade to 2016.2, it shows these messages occasionally.

But it doesn't make any difference, debugging still works.

Thanks.

0

Please sign in to leave a comment.