DataGrip freezing when background processes run

Answered

I just started using DataGrip and for them most part I'm liking it.  However, I keep getting a un-responsive IDE for doing what seems like nothing.  Version 2016.2.  Not sure if there's a checkbox clicked or something else causing this but it basically makes the product useless.

Every time this happens, in the lower right hand corner it says it has a few processes running.  I thought those processes were supposed to be running in the background.?  

A bug fix or some advice on how to prevent this would be great!

 

 

 

 

12 comments
Comment actions Permalink

Same issue.

The main culprit for me seems to be database schema synchronization. For each connection you can switch off Auto Sync, and that certainly helps ... for that one background task.

0
Comment actions Permalink

Turning off Auto Sync seemed to help for me as well.  This is something that didn't happen much in earlier versions, but has got worse in recent releases.  Just for context, I'm using JDBC to connect to a Teradata platform.

0
Comment actions Permalink

Yeah. This is the same problem I just reported. Will try to remove auto sync. 

0
Comment actions Permalink

We discovered this problem, please expect it to be fixed in the closest minor update → DataGrip 2016.2.4.

0
Comment actions Permalink

In 2017.2.1 this problem returned again

0
Comment actions Permalink

We know this, thanks! expect for 2017.2.2 next week

0
Comment actions Permalink

Nothing has changed in 2017.2.2. Even synchronizing one object (package, for example) fully hangs datagrip till the synchronizing has finished

0
Comment actions Permalink

This problem is also occurring in 2018.2. My whole machine is hanging (not just datagrip).

I can manage to get the indexing finished by terminating and restarting Datagrip several times.

0
Comment actions Permalink

@Karl can you please elaborate, what do you do which causes freezing?

Can you please send us logs and thread dumps?

What database do you use?

0
Comment actions Permalink

I have same issue, each morning my macbook grinds for hours until DataGrip process is killed, this is pretty bad. I am going to turn of auto sync as some folks suggested here. I have DataGrip 2018.3 EAP. I usually do have live connection for Cassandra, Oracle etc.

0
Comment actions Permalink

@Ganesh Bhattachan
How is it possible to use 2018.3 EAP?


The current version is 2019.2 EAP. If you experience freeze problems, could you email me vasily.chernov@jetbrains.com your zipped IDE logs folder for further freeze investigation?

0
Comment actions Permalink

My bad, it is DataGrip 3 version that I am having issue. Somehow I forgot to delete expired version 2018.3 EAP. Anyway, I have disabled auto sync on couple of connections last night and I am not experiencing freezing issue this morning. Let me observer next couple of days and will get back to you. Thank you @Vasily

1

Please sign in to leave a comment.