Trouble Syncing and Building Gradle Projects in 2016.2.2

Answered

I seem to be having an issue with 2016.2.2, build #IU-162-1628-40 on an Arch Linux box.  Using Gradle 3.0 that I have installed in a separate directory.  I created a brand new Gradle project and it was missing the src folder structure (had "Create directories for..." option on project creation).  Those were easy enough to add, but when I opened the project the Gradle Sync messages gave me:

Error:org.gradle.listener.ListenerBroadcast.<init>(Ljava/lang/Class;)V

When I try to make the project I get:

Error:Internal error: (java.lang.NoSuchMethodError) com.intellij.util.concurrency.SequentialTaskExecutor.processQueue()V
java.lang.NoSuchMethodError: com.intellij.util.concurrency.SequentialTaskExecutor.processQueue()V
    at org.jetbrains.jps.cmdline.BuildSession$EventsProcessor.startProcessing(BuildSession.java:655)
    at org.jetbrains.jps.cmdline.BuildSession.runBuild(BuildSession.java:291)
    at org.jetbrains.jps.cmdline.BuildSession.run(BuildSession.java:124)
    at org.jetbrains.jps.cmdline.BuildMain$MyMessageHandler$1.run(BuildMain.java:242)
    at org.jetbrains.jps.service.impl.SharedThreadPoolImpl$1.run(SharedThreadPoolImpl.java:44)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)

I can successfully use "gradle build" to compile and run my project from the command line, though.

 Did notice on https://intellij-support.jetbrains.com/hc/en-us/community/posts/206568049-Gradle-throws-exception-on-Sync-or-tasks?flash_digest=7bf9f15125ee93edc308b9b01d415c8713c111f1 that it should have been fixed a couple of versions ago, but I seem to still be having it.  Any suggestions?

2 comments
Comment actions Permalink

Try to reinstall IDEA from http://www.jetbrains.com/idea/download/index.html.

Make sure you unpack it into an empty directory, don't copy over the previous installation.

1
Comment actions Permalink

Yup that fixed it!  I had upgraded over top of an older installation of IntelliJ, deleting the directory and using a new one solved my problem.  Thanks for the help!

0

Please sign in to leave a comment.