Hash (#) key on OS-X not working

Answered

In IDEA the usual [alt][3] on my MacBook does not result in the '#' character. As can be seen from this post, it works normally.

I don't know if this is an issue with this release, which I installed earlier today, or if it is a configuration problem. I can't say if I had a problem before today.

IntelliJ IDEA 2016.2.3
Build #IU-162.1812.17, built on August 30, 2016
JRE: 1.8.0_112-release-b287 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

4 comments
Comment actions Permalink

Thanks for the reply.

Is there a better explanation of the 'JDK Workaround'?

0
Comment actions Permalink

Yes, there is, read the last comment:

Please, specify this jdk as a boot jdk https://bintray.com/jetbrains/intellij-jdk/download_file?file_path=jbsdk8u112b325_osx_x64.tar.gz

1. Download the archive
2. Unpack it
3. Run "Switch IDE boot JDK" action
4. Select "..." in the checkbox
5. Specify the unpacked directory in the file chooser
6. Reboot

0
Comment actions Permalink

BTW to find that action: https://www.jetbrains.com/help/idea/2016.2/switching-boot-jdk.html

I used JDK 1.8.102 which I already had installed on my machine. That worked fine.

0

Please sign in to leave a comment.