RUN simply stopped working for one single project which previously worked fine (no changes to configuration)

Answered

Info:

- Using community edition 2018.1.5 (reinstall didnt help)

- Using Java 1.8.0_121 (exactly the same as from before the issue)

- Reimporting projects didn't help

- Fetching it again in different path - didnt help

- Removing idea folder and iml files didnt help

- Invalidating caches didnt help

- Run button is present while clicking on main function and on main class.

- Run is grayed out next to "THE SAME" run configuration at the top-right (its the same configuration ive used previously - nothing changed)

- There are ZERO logs about what went wrong...

- "Running" application simply does "nothing" - Before Launch "Build" option is completely neglated, who when i rebuild project it works fine

 

Im really buffled, spent like 3 hours now banging my head against it, because it makes no sense.

45 comments
Comment actions Permalink

Please share a sample project to reproduce.

Did you try deleting IDE folders to start from scratch (https://intellij-support.jetbrains.com/hc/articles/206544519)?

-1
Comment actions Permalink

I have few projects with exact same configuration and the issue does not occur for them... I've reinstalled Idea completely and the issue persists which makes no sense to me at all..

0
Comment actions Permalink

Reinstalling IntelliJ IDEA doesn't remove IDE folders mentioned in https://intellij-support.jetbrains.com/hc/articles/206544519 by default. Double check it.

Compare the run configuration files in the projects where it works and where it doesn't work: http://stackoverflow.com/a/3136255/104891.

-1
Comment actions Permalink

Sample project can be any Spring Boot hello world. I've removed configuration folders before installation but either way why does installer even asks whether to reuse previous configuration or not ?

0
Comment actions Permalink

So that you can import the settings from the previous version after updating.

0
Comment actions Permalink

Gotta say its near impossible to compare some idea configuration files..

0
Comment actions Permalink

Found the issue - Gradle plugin in version 181.5281.24, looks like on my previous installation it also updated in "Stealth" mode or i didn't notice it... Disabling Gradle plugin fixed my problem, too bad at the cost of well not being able to use Gradle...

No idea why exactly Gradle plugin conflicts with this one particular multimodule project.

8
Comment actions Permalink

Is it gradle-based project? Could you reproduce the issue and attach the project with the `.idea` folder included to recreate the issue? Please also add idea logs.

0
Comment actions Permalink

Weirdest part its not a gradle-based project but maven one. If i get a moment ill do that.

0
Comment actions Permalink

Add 2 hours of lost life time from my side. I have to keep gradle plugin deactivated for my maven projects.

Build 181.5281.24, JRE 1.8.0_152-release-1136-b39 amd64.

2
Comment actions Permalink

@Bruno Eberhard could you please provide an example project if possible?

0
Comment actions Permalink

@Petr I would like to. But it only happens for our complex projects. A simple 'hello world' does work. I keep an eye on it maybe I stumble upon the trigger of the problem.

0
Comment actions Permalink

I can confirm I had the same issue and disabling the gradle plugin Version: 181.4203.550 also fixed it (even though my project is not even a gradle one but a normal spring boot maven project) 

0
Comment actions Permalink

@Plosson Is it reproducible with new simple project?

0
Comment actions Permalink

Easy to reproduce adding a dependency to Javalin library for lightweight rest server.

After adding it to my project, when pressing run it does nothing and the run button is disabled..

0
Comment actions Permalink

I added Javalin dependency to my sample Maven project, but run button works fine.

0
Comment actions Permalink

Is the gradle plugin disabled or enabled?

What version of Intellij are you using? What version of the gradle plugin are you using?

0
Comment actions Permalink

I checked on 2018.3 EAP with Gradle plugin enabled.

0
Comment actions Permalink

I have also had this happen with maven projects. Currently on 2018.1.3 and Gradle plugin 181.4892.42. I don't know how to reproduce it because everything works fine until it doesn't.

1
Comment actions Permalink

Hello Matt,

Could you please check the issue with 2018.3 EAP?

 

0
Comment actions Permalink

Same problem here. I recreate the project and it works until it stops working again. I then have to recreate it again...

Any way to help debug? It's a big problem for me.

1
Comment actions Permalink

Please report at https://youtrack.jetbrains.com/issues/IDEA with the logs attached (https://intellij-support.jetbrains.com/hc/articles/207241085). Also attach .idea directory contents from the project.

0
Comment actions Permalink

Hello,

I had the same problem. At once run button stop working, it was just doing nothing and after first click was disabled (the same with debug button as well as run icon in the main class/method). I've tried everything with disabling cache and updating Intellij too. As you mentioned above disabling the gradle plugin worked (it's maven project...). However when I finally was able to run my run configuration I saw the error : 

"Error running '...Application': Command line is too long. In order to reduce its length classpath file can be used. Would you like to enable classpath file mode for all run configurations of your project?"

Maybe it was the main reason why Intellij was not able to run project, but it was somehow hidden? Anyway it's very strange why gradle plugin has any influence to this 

Regards

1
Comment actions Permalink

@Pawel Thank for the help. I'll try to see if any of the plugins I use could be causing the problem for me. I don't use gradle.

I forgot to mention I am using Goland IDE.

0
Comment actions Permalink

In my situation, before upgrading to Springboot 2.0 all the Junit tests worked fine, then after upgrading it simply would not run. Click the run button does nothing, no logs either.

Disabling the Gradle plugin resolved my issue. However, preferably someone can find the root cause, in case I need to use Gradle in the future.

0
Comment actions Permalink

Thank you Daniel Hajduk for posting the solution to disable Gradle plugin.

I've lost 4 hours on this. My project is Spring Boot 2 (maven) using IntelliJ Ultimate 2018.1

 

0
Comment actions Permalink

Had the same exact issue described by OP, my solution was also to disable gradle.

My project is a Maven project.
This project was working a month ago.
Other projects with same config were/are working fine.

Thanks Daniel for posting your solution.

Edit: Only difference I can tell is that the project that stopped working was multi-module.

0
Comment actions Permalink

I ran into this issue as well. disabling the gradle plugin worked (it's maven project...).

Thanks for posting your solution. 

2
Comment actions Permalink

Anyone having this issue - it would be of much help to have a sample project where it is reproducible. Thank you.

1

Please sign in to leave a comment.