Column Selection (box select) permanently fattens cursor


Going into column select will visibly fatten the cursor (on my screen it looks something like 3x fatter).  Okidoki.

But hopping out of column selection (and returning to regular selection) does not return the cursor to normal width.  It always stays "looking like" it's still in column selection mode.

I also saw this on 2017.3

I'd supply a screenshot, but there's no point: I can't show the before/after because I'm stuck in the "after".

IntelliJ IDEA 2018.1 EAP (Community Edition)
Build #IC-181.3741.2, built on February 13, 2018
JRE: 1.8.0_152-release-1136-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0


What's the value of this property (Help | Find Action | Registry)?


editor.caret.width == 2.

I wish I can asked it what it was previously.   Is 2 the default for my version/system?


Yes, 2 is the default. See if changing it to 1 helps. Please also attach the screenshot of the cursor that you have now.


Is there sometimes a protracted delay between posting here and me being able to see my post?  I posted a reply and it has yet to show up for me.


Seems like prior post didn't take for some reason, so here's try #2.  Here's the screenshot.  Yes, the setting to 1 makes it thin, which is fine, but I'm not sure why this happened in the first place.  Here it is at width =2, which wasn't showing as this fat until I did column select of something.

Note that in this screenshot I've shown the regular selection so that you can see that it's not currently in column mode.


Cursor and font will scaled according to your display DPI settings, so if you work with 200% DPI scaling, 2 pixel cursor will be 4 pixels on the screen.


....Except that I'm at 100% scaling:

Also, the problem as I see it is that I started with something akin to a 1 pixel wide cursor (similar to the default cursor used in entering text fields in the Intellij IDEA gui, like the search bars), but it visibly switches to fat when I go into column mode, but never returns to thin again when I leave column mode.  I'm not sure it even matters that editor.caret.width was always 2, because the cursor used to be thin.  This is odd.

Forget the value in the registry, my additional question is this: Is the pixel supposed to get fatter when column select is enabled?  If so, is it a bug when it doesn't go back?


Column selection mode isn't expected to have any impact on caret width in an out-of-the-box IDEA. Maybe this is caused by some plugin. Do you have any third-party ones installed?


No, at least nothing I specifically went out of my way for (I don't know if there are 3rd party relationships with JetBrains that allow for 3rd party stuff shipped with IDEA).

Can I do an re-install of the IDEA EAP without inheriting anything at all from my existing two other installs (2017.3 & 2018.1 EAP)?  As in, not even the Win10 registry?

I'd like to post before and after photos.


You can temporary rename your config/settings folder to run with default settings. On Windows it's $USER_DIR$/.IdeaIC2018.1. After your experiment you can remove newly created folder and replace it with the old one.


And..................................................I can't seem to duplicate it.


I'll see if it happens again I guess.

Thanks anyway.  I can live with the behavior as it is now, so no worries.


Please sign in to leave a comment.